1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

ASP.Net Issues

Discussion in 'Plesk for Windows - 8.x and Older' started by group39, Oct 29, 2004.

  1. group39

    group39 Guest

    0
     
    ASP.Net Problems

    I have a couple of sites running under plesk. I recently tried to do a simple asp.net test page and I am getting and error. I have a web.config file in the root of my site I am using that will allow the error message to be shown to remote computers. The site is not recognizing it because I just get the default error page that tells me to set this in web.config
    <!-- Web.Config Configuration File -->
    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>

    That is already set. Anyone have any ideas on how to fix this issue.

    Thanks
     
  2. chrisz7

    chrisz7 Guest

    0
     
    Hi Group39,

    Pretty quiet in here eh?!

    Looks like for some reason your .net app isn't using your Web.config file. Perhaps this is because of an error in the config file or it has been uploaded into the wrong folder.

    Is the config file working on your local machine (or your test area)?

    Which folder have you uploaded it to? (should be httpdocs folder)

    Are you using anything in the config that isnt compatible with .net 1.1? (i haven't looked at .net 2 but if you are using that then perhaps something in there is not backwards compatible.)

    if you want, post your config file here and i'll have a look.
     
  3. group39

    group39 Guest

    0
     
    Here is what is in my web.config

    Listed below is what I have my web.config file as. It is in the httpdoc folder. Thanks for taking a look.


    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>

    <system.web>

    <!-- DYNAMIC DEBUG COMPILATION
    Set compilation debug="true" to insert debugging symbols (.pdb information)
    into the compiled page. Because this creates a larger file that executes
    more slowly, you should set this value to true only when debugging and to
    false at all other times. For more information, refer to the documentation about
    debugging ASP.NET files.
    -->
    <compilation defaultLanguage="vb" debug="true" />

    <!-- CUSTOM ERROR MESSAGES
    Set customErrors mode="On" or "RemoteOnly" to enable custom error messages, "Off" to disable.
    Add <error> tags for each of the errors you want to handle.

    "On" Always display custom (friendly) messages.
    "Off" Always display detailed ASP.NET error information.
    "RemoteOnly" Display custom (friendly) messages only to users not running
    on the local Web server. This setting is recommended for security purposes, so
    that you do not display application detail information to remote clients.
    -->
    <customErrors mode="off" />

    <!-- AUTHENTICATION
    This section sets the authentication policies of the application. Possible modes are "Windows",
    "Forms", "Passport" and "None"

    "None" No authentication is performed.
    "Windows" IIS performs authentication (Basic, Digest, or Integrated Windows) according to
    its settings for the application. Anonymous access must be disabled in IIS.
    "Forms" You provide a custom form (Web page) for users to enter their credentials, and then
    you authenticate them in your application. A user credential token is stored in a cookie.
    "Passport" Authentication is performed via a centralized authentication service provided
    by Microsoft that offers a single logon and core profile services for member sites.
    -->
    <authentication mode="None" />


    <!-- AUTHORIZATION
    This section sets the authorization policies of the application. You can allow or deny access
    to application resources by user or role. Wildcards: "*" mean everyone, "?" means anonymous
    (unauthenticated) users.
    -->
    <authorization>
    <allow users="*" /> <!-- Allow all users -->

    <!-- <allow users="[comma separated list of users]"
    roles="[comma separated list of roles]"/>
    <deny users="[comma separated list of users]"
    roles="[comma separated list of roles]"/>
    -->
    </authorization>

    <!-- APPLICATION-LEVEL TRACE LOGGING
    Application-level tracing enables trace log output for every page within an application.
    Set trace enabled="true" to enable application trace logging. If pageOutput="true", the
    trace information will be displayed at the bottom of each page. Otherwise, you can view the
    application trace log by browsing the "trace.axd" page from your web application
    root.
    -->
    <trace enabled="false" requestLimit="10" pageOutput="false" traceMode="SortByTime" localOnly="true" />


    <!-- SESSION STATE SETTINGS
    By default ASP.NET uses cookies to identify which requests belong to a particular session.
    If cookies are not available, a session can be tracked by adding a session identifier to the URL.
    To disable cookies, set sessionState cookieless="true".
    -->
    <sessionState
    mode="InProc"
    stateConnectionString="tcpip=127.0.0.1:42424"
    sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes"
    cookieless="false"
    timeout="20"
    />

    <!-- GLOBALIZATION
    This section sets the globalization settings of the application.
    -->
    <globalization requestEncoding="utf-8" responseEncoding="utf-8" />

    </system.web>

    </configuration>
     
  4. chrisz7

    chrisz7 Guest

    0
     
    Hi,

    Looks fine apart from the customErrors tag:

    <customErrors mode="off" />

    needs to be

    <customErrors mode="Off" />

    because the config files are case sensitive.

    I hope this helps.
     
  5. group39

    group39 Guest

    0
     
    No Luck

    I tried the case sensitive change and had no luck. Thanks for taking a look for me.
     
Loading...