1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ASP.NET Settings per Domain crashes IIS

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by Linearg.com, Jun 25, 2011.

  1. Linearg.com

    Linearg.com Guest

    0
     
    We have a fresh install of Windows 2008 R2 and IIS and Plesk. This is the first domain with ASP Code. The ASP code runs but I need to make a modification to the database string. I went into the domain settings and clicked on ASP.NET Settings. After 30 seconds I get the below error then checking the Event log it appears IIS crashed. But the ASP.NET Settings for Plesk global settings/defaults works fine.. As this is a fresh install, I have nothing to go back to.

    I've read all the knowledge base and tried running a few fixes with no effect... But this is a fresh install, so there shouldn't be any errors to fix.....

    Can you please help. I can't let clients crash the server just by using the Plesk Panel.

    When opening ASP.NET Settings on a domain I get this after 30 seconds:
    ASPdotNet() constructor failed: Unable to getDomainConfiguration: aspnetcfg failed: Windows: Server execution failed
    ---------------------- Debug Info -------------------------------
    0: ASPDotNETUIPointer.php:69
    ASPDotNETUIPointer->accessItem(string 'GET', NULL null)
    1: UIPointer.php:600
    UIPointer->access(string 'GET')
    2: plesk.php:47

    However the Server/Global ASP.NET Settings works.

    Here is the EVent Log:

    Log Name: System
    Source: Service Control Manager
    Date: 24/06/2011 8:31:15 PM
    Event ID: 7023
    Task Category: None
    Level: Error
    Keywords: Classic
    User: N/A
    Computer: arakkis
    Description:
    The IIS Admin Service service terminated with the following error:
    The system cannot find the file specified.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="Service Control Manager" Guid="{555908D1-A6D7-4695-8E1E-26931D2012F4}" EventSourceName="Service Control Manager" />
    <EventID Qualifiers="49152">7023</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-06-24T10:31:15.000Z" />
    <EventRecordID>68010</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>System</Channel>
    <Computer>arakkis</Computer>
    <Security />
    </System>
    <EventData>
    <Data Name="param1">IIS Admin Service</Data>
    <Data Name="param2">%%2</Data>
    </EventData>
    </Event>

    And

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
    <Provider Name="aspnetcfg.exe" />
    <EventID Qualifiers="0">0</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-06-24T10:27:30.000Z" />
    <EventRecordID>61</EventRecordID>
    <Channel>Plesk</Channel>
    <Computer>arakkis</Computer>
    <Security />
    </System>
    - <EventData>
    <Data>System.NullReferenceException: Object reference not set to an instance of an object. at realdev.net.idna.DnsIDNA.toUnicode(String input) at ASPNETConfigure.ASPNETCfgApp.run(String[] args) at ASPNETConfigure.ASPNETCfgApp.Main(String[] args)</Data>
    </EventData>
    </Event>

    As mentioned above, we can't have plesk killing IIS, especially with a fresh install..
    Thanks,
    Daeta.
     
Loading...