1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ASP / PHP / PERL on Websites not working

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by D3nnis3n, Mar 2, 2012.

  1. D3nnis3n

    D3nnis3n Regular Pleskian

    27
     
    Joined:
    May 12, 2008
    Messages:
    125
    Likes Received:
    1
    Hello,
    i can't use PHP / ASP / PERL etc. on my websites - i keep getting error 500 on visiting such pages.
    Even the official standard testpages for PHP, ASP, Python and Perl on newly created domains give me error 500.

    What to do!?
     
  2. D3nnis3n

    D3nnis3n Regular Pleskian

    27
     
    Joined:
    May 12, 2008
    Messages:
    125
    Likes Received:
    1
    Hello,
    this is the Error im getting by IIS:
    C:\Program Files (x86)\Parallels\Plesk\admin\bin\php-cgi.exe - Der FastCGI-Prozess wurde unerwartet abgebrochen.

    (FastCGI Process has been terminated unexpectedly)

    What to do?
     
  3. Dave Navarro

    Dave Navarro Guest

    0
     
    Same Troubles

    Hello,

    I'm having the same troubles. Have you found a solution? And if so, can you share what you did to resolve this issue?

    Please let me know and thanks!

    ~ Dave
     
  4. Webyhost!

    Webyhost! New Pleskian

    13
    35%
    Joined:
    Dec 6, 2011
    Messages:
    17
    Likes Received:
    0
    I had the same problem and I searched over the net with no luck.
    This occurred after I upgraded from plesk 9.8 to plesk 10.4.
    I had a couple of domains with some old IP's that were no longer in use and I noticed the IP inside of IIS.
    I removed the IP in plesk and re-added the correct IP.
    If this fails, try changing the IP in IIS just to try it out.
    I also had some IP errors for some sites in event viewer and noticed my sites with ssl had the ssl ip entry multiple times in IIS.

    I just removed them and just kept one.

    The error message is confusing because it leads you to believe php is not installed properly and it has nothing to do with it. Just make sure in your IIS configuration that .php is there and pointing to the right path using "quotes".

    Jorge
     
Loading...