1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Atmail problem

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by xtreme2490, Jan 5, 2009.

  1. xtreme2490

    xtreme2490 Guest

    0
     
    I get :

    Warning: main() [function.main]: open_basedir restriction in effect. File(/Global.php) is not within the allowed path(s): (/var/www/atmail:/var/log/atmail:/etc/psa:/tmp:/var/tmp) in /var/www/atmail/index.php on line 67

    Warning: main(Global.php) [function.main]: failed to open stream: Operation not permitted in /var/www/atmail/index.php on line 67

    Fatal error: main() [function.require]: Failed opening required 'Global.php' (include_path=':libs/Atmail:libs/PEAR:libs') in /var/www/atmail/index.php on line 67


    Running Plesk 9.0.2 on FC4
     
  2. xtreme2490

    xtreme2490 Guest

    0
     
    *** Bump ***

    Anyone ??
     
  3. xtreme2490

    xtreme2490 Guest

    0
     
    Nobody ????
     
  4. gorilych

    gorilych Guest

    0
     
    where do you get this error? on login page?
     
  5. xtreme2490

    xtreme2490 Guest

    0
     
    Indeed , when i try to login.
    Doesn't matter which domain it is . If i select Atmail as webmail client , i get the above error when trying to access webmail.
     
  6. steogede

    steogede Guest

    0
     
    Hi xtreme2490, I don't have a fix for you problem, but I thought I would respond seeing as nobody else has. Your error messages, seem contradictory. The bit that really has me stumped is the File(/Global.php).

    I would check line 67 of /var/www/atmail/index.php - mine says "require_once('Global.php');" - if yours has a slash before 'Global' that will be the problem.

    Otherwise, why is it resolving 'Global.php' to '/Global.php' - all I can assume is that it is a bug in php as '/' isn't (and shouldn't be) in your include_path (only 'libs/Atmail', 'libs/Pear' and 'libs' are - the same as my working Atmail on COS5) so why it would resolve to '/Global.php' I can't say.

    Something I did notice is that you are using FC4, I would recommend that you consider upgrading to a newer distro. Although FC4 is supported, it can sometimes be difficult update PHP once Plesk is installed - a fresh install on FC8 or COS5.2 or any recent distro you prefer, might be more trouble (I'll leave it to you to decide if it is worth the hassle of upgrading).
     
  7. xtreme2490

    xtreme2490 Guest

    0
     
    In global.php on line 67 there's no leading / , it says : require_once('Global.php');
     
  8. minichip

    minichip New Pleskian

    22
     
    Joined:
    Feb 1, 2009
    Messages:
    3
    Likes Received:
    0
    Hi xtreme2490,

    I have exactly the same error, well I am on a Ubuntu sytem so I have a sligthly different path where plesk and atmail are installed, but I have the same error about "File(/Global.php)".

    The solution is quite simple. Log into your system and open the file /var/www/atmail/header.php. It should look like

    Change it into

    notice the dot at the beginning of the $path variable and your good to go.
    Well at least it solved the problem for me in plesk 9.0.0 and after the update to 9.0.1

    best regards
     
  9. xtreme2490

    xtreme2490 Guest

    0
     
    That did it , thnx.

    I'm still having problems to login, but atleast some mailboxen can use it now.

    Only when i use a mailbox that contains not to many mails , it works.
    If i use a mailbox that has 100 mails in it , than i cannot login .

    Someone ?
     
  10. xtreme2490

    xtreme2490 Guest

    0
     
    I've found it :

    The cause is bad characters in a subject field which breaks the XML. All data is contained in a CDATA block to reduce the possibility of this however it can still happen with some characters (e.g control characters).

    This is a bug in version Atmail 5.3.

    Parallels please update Atmail !!!
     
Loading...