1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

autoinstaller aborted - restart ?

Discussion in 'Plesk for Linux - 8.x and Older' started by dl2rbi, Jul 12, 2009.

  1. dl2rbi

    dl2rbi Guest

    0
     
    I tried to update plesl 8.2.1 to newer version 8.6 with via SSH-connection on linux. (parallels_installer_v3.3-9.09_os_SuSE_10.0_x86_64. After about 2 minutes the SSH-link was brocken. The installation was aborted. If I try to start the autoinstaller again, a dependency-problem is shown, because some packages like qmail are newer than version 8.2.1. The autoinstaller stops at the beginning ...

    How can I solve this problem ... ? Is there a command-line switch to force the installation, even a dependency problem exists ? The qmail package (maybe some others, too) is updated already to PLESK 8.6, others are on 8.2.1 ....

    werner
     
  2. Yulia Kostina

    Yulia Kostina Guest

    0
     
    Hello

    For now it is not clear why autoinstaller was aborted, there should be exact error messages in /tmp/autoinstaller3.log file.
    Anyway, it is not always good idea to reinstall everytying forcibly, if most of the packages are still of 8.2.1 version it is better to remove 8.6 packages and start upgrade using autoinstaller again.
    If you want to forcibly upgrade without depencendy check you can download the whole distribution of Plesk 8.6:
    http://download1.parallels.com/Ples...1-suse10.0.build92090212.19.x86_64.rpm.tar.gz
    then unpack it:
    tar xzf psa-9.2.1-suse10.0.build92090212.19.x86_64.rpm.tar.gz
    you will have unpacked directories with Plesk packages. You can try to complete installation with (for example):
    rpm -Uvh --force base/*.rpm opt/api/*.rpm opt/backup/*.rpm opt/migration/*.rpm

    It is necessary to do from within the unpacked directory.
     
  3. dl2rbi

    dl2rbi Guest

    0
     
    autoinstaller logfile

    Hello,

    thank vou for answer. The reason for the aborted installation was the broken ssh-link to the server, because of restarting the local router. The autoinstaller was killed via sshd-daemon, I think.

    Here are the last lines of autoinstaller-log:

    First fit build is current best: PSA_8.6.0/plesk-8.6.0-suse10.0-x86_64.inf3
    Select best build: finally choised PSA_8.6.0/plesk-8.6.0-suse10.0-x86_64.inf3
    Downloading the file PSA_8.6.0/plesk-8.6.0-suse10.0-x86_64.inf3: Filefetcher: get file PSA_8.6.0/plesk-8.6.0-suse10.0-x86_64.inf3
    100% done.
    build for Linux SuSE 10.0 x86_64 (/root/psa/PSA_8.6.0/plesk-8.6.0-suse10.0-x86_64.inf3) is fit
    repository: Get brief packages info for all sources
    Detecting installed product components.
    Component base: mode upgrade, installed=1190095312, available=1216667718
    No keyupdate need for component base
    Component psa-autoinstaller: mode upgrade, installed=1189762152, available=1215656574
    Component asp: mode upgrade, installed=1190095608, available=1200370735
    Component mailman: mode install, installed=0, available=1216667888
    Component postgresql: mode install, installed=0, available=1177950688
    Component java: mode install, installed=0, available=1216667650
    Component spamassassin: mode upgrade, installed=1190095101, available=1216667658
    Component rblsmtpd: mode upgrade, installed=1190095094, available=1216667654
    Component mod_python: mode up2date, installed=1190802581, available=1190802581
    Component ruby: mode install, installed=0, available=1216667899
    Component fcgi: mode install, installed=0, available=1160390720
    Component vault: mode install, installed=0, available=1216667924
    Component docs: mode upgrade, installed=1190095475, available=1216667809
    Component backup-ded: mode upgrade, installed=1190095595, available=1222720565
    Component drweb: mode upgrade, installed=1190094981, available=1216667571
    Component kav: mode upgrade, installed=1190095665, available=1216667915
    Component ppwse: mode upgrade, installed=1190095551, available=1216667860
    Component api: mode upgrade, installed=1190095060, available=1222720561
    Component sshterm: mode upgrade, installed=1190094847, available=1216667490
    Component pmm: mode up2date, installed=1222720568, available=1222720568
    Component psa-firewall: mode upgrade, installed=1190095082, available=1216667647
    Component cs-gs: mode install, installed=0, available=1216667641
    Component psa-vpn: mode upgrade, installed=1190095458, available=1216667798
    Component battlefield: mode install, installed=0, available=1216667842
    Component bf2: mode install, installed=0, available=1216667892
    Component psa-fileserver: mode install, installed=0, available=1216667626
    Component watchdog: mode upgrade, installed=1190095581, available=1221225203
    Component sb-publish: mode install, installed=0, available=1160553153
    Component sbm: mode install, installed=0, available=1210144475
    Component cf-support: mode install, installed=0, available=1216667893
    Component atis: mode install, installed=0, available=1214312443
    Component miva: mode install, installed=0, available=1216667908
    Component mod-bw: mode install, installed=0, available=1194430119
    Component billing: mode install, installed=0, available=1218621008
    Component de-DE-locale: mode upgrade, installed=1190032171, available=1217925532
    Component ja-JP-locale: mode install, installed=0, available=1216193043
    Component es-ES-locale: mode install, installed=0, available=1216193035
    Component ru-RU-locale: mode install, installed=0, available=1216193052
    Component fr-FR-locale: mode install, installed=0, available=1216193038
    Component it-IT-locale: mode install, installed=0, available=1216193040
    Component zh-CN-locale: mode install, installed=0, available=1216193055
    Component zh-TW-locale: mode install, installed=0, available=1216193058
    Component nl-NL-locale: mode install, installed=0, available=1217925546


    Autoinstaller 3.3.2 (build at 2008-07-10 09:20 svn rev. 0) started at (timezone CET) Sat Jul 11 16:41:10 2009
    Command line args: ./parallels_installer_v3.3.2_build080710.09_os_SuSE_10.0_x86_64


    The last line was the trial to restart the installation with failed on the following dependency errors

    (s) system_installed_libstdc++-4.0.2_20050901-3.x86_64.rpm
    (s) system_installed_zlib-1.2.3-3.x86_64.rpm
    Paket wird installiert psa-hotfix3-8.6.0-suse10.0.build86080822.19.x86_64, psa-8.6.0-suse10.0.build86080722.00.x86_64, psa-libpam-plesk-8.6.0-suse1Execute command rpm -U --test /root/parallels/PSA_8.6.0/dist-rpm-SuSE-10.0-x86_64/base/psa-hotfix3-8.6.0-suse10.0.build86080822.19.x86_64.rpm /rooerror: Failed dependencies:
    psa = 8.2.1 is needed by (installed) psa-migration-manager-8.2.1-suse10.0.build82070918.10
    psa = 8.2.1 is needed by (installed) psa-backup-manager-8.2.1-suse10.0.build82070918.10
    psa-api = 8.2.1-suse10.0.build82070918.10 is needed by (installed) psa-migration-manager-8.2.1-suse10.0.build82070918.10
    psa-api-rpc = 8.2.1-suse10.0.build82070918.10 is needed by (installed) psa-backup-manager-8.2.1-suse10.0.build82070918.10
    -- Check for new version of PSA_8.6.0/plesk-8.6.0-suse10.0-x86_64.inf3
    Filefetcher: get file (~empty)/PSA_8.6.0/plesk-8.6.0-suse10.0-x86_64.inf3
    Execute command /usr/sbin/getenforce
    Disabled
    ERROR: Unable to install the requested packages because of package dependency problems.
    Warnung! Es wurden nicht alle Pakete installiert.
    Bitte prüfen Sie, ob Ihre Systemdienste betriebsbereit sind.
    Bitte kontaktieren Sie den technischen Produktsupport.


    If you need more information, plese let me know - I could send you the whole log-files, if needed

    Thank you

    Werner
     
  4. Yulia Kostina

    Yulia Kostina Guest

    0
     
    There is some packages of Plesk 8.6 installed, you need to find and remove them, then you will be able to complete the upgrade using autoinstaller. Use "rpm -qa | grep psa" and check which packages have newer version. You can remove
    them only from rpm database with (for example):
    rpm -e psa-backup-manager-vz-9.2.1-cos5.build92090422.13 --nodeps --justdb
     
  5. dl2rbi

    dl2rbi Guest

    0
     
    directly update from 8.2.1/8.6 to 9.2.1

    thank for the uninstall information.

    Is it posible to update to plesk 9.2.x directly from the existing mixed 8.2.1 / 8.6 version ?
    Maybe the dependency check will not fail, because of newer version (v9.2.x) ?
     
  6. Yulia Kostina

    Yulia Kostina Guest

    0
     
    Hello

    Yes, it is possible, at least you can try.
     
  7. olivierz

    olivierz Guest

    0
     
    hello,
    i have this problem ! i have upgrade my plesk 8.6 to 9.2.2. and now, i have some troubles.
    I has plesk 8.6 with dr web. Now plesk tell me that my license drweb is not available. -> my mails are blocked !
     
Loading...