• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Backup warning after upgrading to 12.5

H9k

Regular Pleskian
I upgraded a server from Plesk 12.0 to 12.5 running Debian 7.
All seems fine, except now I get a warning for one specific domain only in the backup tasks:

Hosting on domain xyz.tld is skipped from backup due to error: Can't use string ("") as a HASH ref while "strict refs" in use at /opt/psa/PMM/agents/PleskX/PleskX.pm line 4713.

What could be the cause?
 
Except I am not uplading anything to FTP, plus my error is in PleskX.pm and not DAL.pm and only appeared with Plesk 12.5.
Also, I don't have any problems with maillog, curl or sitebuilder as suggested in the article.
 
I tried the plesk repair utility, also ran the plesk repair installation, but nothing helped. Still getting that error...
 
Ahhh ok, yeah actually the domain logged had hosting, but it had some aliases without hosting...
Thanks, will update and be happy i guess :)
 
Back
Top