1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

best upgrade approach

Discussion in 'Plesk for Linux - 8.x and Older' started by next-step, Dec 19, 2005.

  1. next-step

    next-step Guest

    0
     
    We have plesk 7.0.2 installed + qmail-scanner1.20 + spamassasin 2.x + mysql4 by art

    All this installed on RedHat 9

    what is best approach to setup 7.5.4?

    should I upgrade Plesk to v7.1 before 7.5 installing?
     
  2. bandurao

    bandurao Guest

    0
     
    Hello,


    You have to upgrade the plesk one y one that 7.2 then 7.3 so to 7.5.

    Following are the steps to upgrade from 74. to 7.5:


    Steps to upgarde Plesk are as follows:



    Login to the server you are planning to upgrade, and get a root shell.

    First thing to do is to check whether or not the server is accepting "ping" requests. You need to check this because the plesk rpm in the pre-install script checks this, and if it gives no reply, it dies. So, run the following:

    ping localhost

    If you get nothing but this message for a couple secconds, cancel the command:

    PING localhost.localdomain (127.0.0.1) 56(84) bytes of data.

    When you cancel, you should see 100% packet loss, such as the following:

    --- localhost.localdomain ping statistics ---
    3 packets transmitted, 0 received, 100% packet loss, time 2015ms

    Ping is an icmp packet. First, you want to stop the firewall:

    service iptables stop

    Will output:

    Flushing all chains: [ OK ]
    Removing user defined chains: [ OK ]
    Resetting built-in chains to the default ACCEPT policy: [ OK ]

    Now, you have to make sure the kernel isn't going to ignore the ping requests either, run the following command:

    echo 0 > /proc/sys/net/ipv4/icmp_echo_ignore_all

    Now try the ping again:

    ping localhost
    PING localhost.localdomain (127.0.0.1) 56(84) bytes of data.
    64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=1 ttl=64 time=0.071 ms
    64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=2 ttl=64 time=0.040 ms

    --- localhost.localdomain ping statistics ---
    2 packets transmitted, 2 received, 0% packet loss, time 999ms
    rtt min/avg/max/mdev = 0.040/0.055/0.071/0.017 ms

    You are now ready to continue.


    mkdir psa

    What I did is basically make a /root/psa/ directory

    Now, move into the directory

    cd psa

    Recursivly copy the /etc/psa and /usr/local/psa directries into here. Make sure you name them as different files so you don't overwrite them.

    cp -rp /etc/psa/ etc_psa
    cp -rp /usr/local/psa/ psa

    Do a mysqldump of the psa database, nameing it psa.sql

    mysqldump --opt -u admin -p********** psa > psa.sql

    Looking at the directory you are in, it should look like:

    etc_psa
    psa
    psa.sql

    Now

    Expand the tarball archive:

    change directory into the "base", which contains all the core plesk rpms


    now test it
    rpm -Uvh --test *

    If test gives some dependencies then install those. Once done again test it.

    once done stop all plesk services.

    Now, run the rpm command to upgrade without the --test switch: rpm -Uvh *

    So on it goes, upgrading the server.

    When it comes to this point in the upgrade, it will pause the output:


    ===> Installing Quotas
    Trying to change mount options in /etc/fstab... done
    Checking quotas. This may take some time.
    his will take WAY too long, is isn't nessisary, so background the upgrade process with Ctrl-z

    [1]+ Stopped rpm -Uvh *

    Now, kill the quotacheck processes

    killall -9 quotacheck

    Now forground your shell back into the upgrade, to continue. It'll look something like this:

    fg
    rpm -Uvh *
    /usr/local/psa/bin/install_post.sh: line 16630: 5695 Killed quotacheck "$vhosts_fs" -vunfmc >>"$product_log" 2>&1
    Unable to check quota. Quota is not supported by your operating system

    All other things it does where it pauses for a while, are things that need to be done, and can take a bit of time if there are a lot of domains setup on the server. These things include, but are not limited to: installing chroot enviroment, updating dns records, etc

    When it finishes, you should get a message such as this one:

    ==================================================
    ================
    All stages of the upgrade were successful.
    Plesk is now running on your system.
    To complete the system configuration process, please proceed to URL:



    Further, use the following commands to start and stop the system:
    /etc/rc.d/init.d/psa start and
    /etc/rc.d/init.d/psa stop respectively.

    WARNING: Some minor problems occured during upgrade. You need to *
    * check log file *
    * /tmp/psa_7.0.4_RedHat_9_build040723.13_upgrade.log *
    * to fix these problems. *

    ==================================================
    ================
     
  3. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Or you can download the autoinstaller from the sw-soft site. I have had little problem with it as long as you use it to upgrade only the base package of Plesk. Once you get up to 7.5.4 you can use the control panel's Updater feature.

    Another option is ART's yum project. Check it out at:

    http://www.atomicrocketturtle.com/m...ns&file=index&req=viewarticle&artid=18&page=1

    I have occasionally used this for updates and even installs of Plesk.
     
  4. next-step

    next-step Guest

    0
     
    thanks a lot for such good explanations guys - I will work in a week on this and will let you know
     
  5. next-step

    next-step Guest

    0
     
    auto installer is not working for me cause it conflicts with mysql 4 installed

    yum is not working enough well too cause not contents many optional rpms
     
  6. next-step

    next-step Guest

    0
     
    I have installed Plesk 7.1.7 from yum art repository.

    Now I downloaded 7.5.4 full packacge from Plesk website and tried to launch
    rpm -Uvh <list of base rpms>

    it says
    Please help me with that, thank you
     
  7. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    That's a common problem.

    #rpm -e maildrop

    It may ask to delete other things to solve dependencies. That's OK.
     
  8. next-step

    next-step Guest

    0
     
    it looks like I met a problem:

    first upgrade went bad - it said something about tomcat component record wrong and I sorted out that. But now I have 2 psa versions
    I have tried to delete record in rpm database to make new upgrade:
    but it is just frozen.

    I also tried to make rpm -Uvh --force psa-7.5.4-rh9.build75050824.12 and it is frozen too after all checking done there

    I dont have an idea what can make rpm installator/deinstallator frozen
     
  9. next-step

    next-step Guest

    0
     
    ok I just rebooted server and rpm goes well

    I have finished upgrade to 7.5.4 and going to setup hotfixes and components.
    see below main commands I used:
    # mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa -e"drop database psa"
    # mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa -e"create database psa"
    # mysql -uadmin -p`cat /etc/psa/.psa.shadow` -e"create database psa"
    # mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa < /var/lib/psa/dumps/mysql.preupgrade.dump
    ERROR 1050 at line 10874: Table 'horde_categories' already exists
    # mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa -e"delete from Components where name='tomcat';"
    # rpm -Uvh --force psa-7.5.4-rh9.build75050824.12.i586.rpm psa-key-7.5-rh9.build75050824.12.noarch.rpm
     
Loading...