1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Big SSL Problem

Discussion in 'Plesk for Windows - 8.x and Older' started by 0wn4g3, Apr 26, 2005.

  1. 0wn4g3

    0wn4g3 Guest

    0
     
    What were using.


    Web Server Microsoft IIS 6.0
    psa-autoupdate 1.1.1811.16691
    Web scripting Microsoft ASP 6.0.3790.1830
    Microsoft ASP.NET 1.1.4322.0
    perl v5.8.3 built for MSWin32-x86-multi-thread
    python 2.3.2
    php 4.3.9 (cgi-fcgi) (built: Sep 21 2004 14:04:26)
    Web Publishing Microsoft FrontPage 5.0.2.6738
    FTP Server Microsoft IIS 6.0
    Database Engine Microsoft SQL server 8.00.194
    mysql 4.0.20a-nt
    Mailing list software Mail Enable 1.54
    Mail Server Mail Enable 1.54
    Java JDK 1.4
    Tomcat 5.0.19
    Web statistics webalizer V2.01-10-RB02 (Windows NT 5.2 Service Pack 1) English
    awstats 6.0 (build 1.1)
    DNS Server Plesk DNS Server 9.2.3
    WebMail webmail 3.2.2
    ColdFusion
    Spam filtering SpamAssassin 2.63
    Antivirus filtering Dr.Web 4.32.2.12010 last update 22.04.2005
    Backup psa-bu 7.0.0-win.build041216.03 (1.0.1811.16649)
    Expand Agent pleskagent 1.3.2.3



    Here is my problem. I went into plesk and for the server I added a certificate. I have the text for the private key and the actual certificate text that I put into the correct fields within plesk. I then click the button that says submit text and my certificate is generated and then it shows up in the list of SSL certificates. So what I do then is check mark the box next to the certificate and click the SETUP button which installs the certificate into plesk. Now I set the certificate to be the default and that’s when I think done. So now I go to Domains and go to my domain and then click the certificates button in this window. I create the certificate in the same manner as I did for the server except this time I don’t have the option to set it as the default because it’s the only certificate in the list.

    I use firefox as my browser and when I go to the Plesk Login page I receive a popup notification telling me about the certificate and when I look at the details indeed it is the certificate I setup in plesk. The address for the login to plesk begins with https and works. However ANYWHERE outside of plesk HTTPS brings users to a 404 page. For example our billing system is modern bill. I have modern bill setup to use an SSL certificate however when customers go to login and the address changes from http to https it goes to a 404 page. This is my main problem. Nothing outside of plesk is correctly using the SSL certificate. What gives?
     
  2. cretaman

    cretaman Guest

    0
     
    I'm not quite sure since I'm new to both Plesk and SSL certificates but I had to go to the server level, click on the IP Addresses icon, select an IP address that is exclusive, clik on it and in the pop-up that appears select your new certificate.

    Hope this helps.
     
  3. 0wn4g3

    0wn4g3 Guest

    0
     
    Well I tried your suggestion and I did see that the IP address is shared and the certificate was set to the default one. So I changed it to the GeoTrustSSL one I configured and it still didnt work. Thanks for your suggestions though.
     
  4. cretaman

    cretaman Guest

    0
     
    *** far as I know, the IP address must be EXCLUSIVE, not shared! Somewhere in this forum I read that changing from shared to exclusive requires some more manipulation (as opposed to an IP address that was exclusive right from the start). See http://forum.plesk.com/showthread.php?s=&threadid=23118
     
  5. chuck.boyer

    chuck.boyer Guest

    0
     
    I have a similar problem...

    When I go into the IP Pool for the client, click on the appropriate IP address, my IP is set to exclusive, SSL Cert is set to the appropriate cert, but the default domain is set to none.

    Any ideas?

    Thanks.
     
  6. cretaman

    cretaman Guest

    0
     
    Chuck: In the IP Pool at the Client level there is a list of IP addresses. The far right column says "Hosting". Click on the number that you see in the row of the IP address that you are managing. Does it have a domain linked to it? If not, I think your domain should be addded there. If your domain is allready there, try setting it to default.

    DISCLAIMER This is all new to me too, so I don't really know what I'm talking about :confused:

    Own4g3: In my previous message where I said that you had to go to the Server level, I might have made a mistake, and it should actually be the Client level for you. I guess it depends on whether you set the SSL system wide or for just one domain. But the disclaimer above is still valid. :rolleyes:
     
  7. chuck.boyer

    chuck.boyer Guest

    0
     
    Pure genious. That fixed it. Thanks.
     
  8. 0wn4g3

    0wn4g3 Guest

    0
     
    Just to put this issue at rest, Because of the enormous amount of problems server wide we did an os reload and built everything from scratch but also upgraded to plesk 7.5 We setup one ip address to be exclusive and host our company domain on that one ip address. In the settings for the domain I tell it to use the GeoTrust SSL certificate I installed and everything seems to be working great now.
     
  9. asterisk

    asterisk Guest

    0
     
    Ownage, may I please ask how did you do that in a step-by-step fashion please? I got to the point where you did in your first posting on this thread and am pretty much at a lost. I happen to use Plesk 7.5 as well.

    Many thanks.
     
  10. 0wn4g3

    0wn4g3 Guest

    0
     
    It's been so long since I have gone into Plesk. Shortly there after we left Plesk alone and went to cPanel. So I can't really help you as I don't know exactly what I did.
     
Loading...