1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

bind not starting

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by carpman, Aug 3, 2009.

  1. carpman

    carpman Guest

    0
     
    Hello, ok having issues starting bind on fresh server and plesk install.

    bind fails to start from both CP and console, checking logs i see:

    Code:
    ubuntu kernel: [502063.119247] audit(1249287880.976:58): type=1503 operation="inode_permission" r
    equested_mask="::r" denied_mask="::r" name="/var/named/run-root/etc/localtime" pid=4082 profile="/usr/sbin/named"                                                                  namespace="default"
    
    Plesk 9.2.2
    Ubuntu 8.04.3 LTS 64bit

    any ideas?

    cheers
     
  2. abezborodova

    abezborodova Guest

    0
     
    The error said that it was SELinux that prevented bind starting.
    Use command setenforce to disable it in current session.

    To check SELinut mode:

    ~# getenforce

    To switch mode to Permissive:

    ~# setenforce 0

    To disable SELinux completely it is recommended to change the mode in /etc/selinux/config

    ---
    # This file controls the state of SELinux on the system.
    # SELINUX= can take one of these three values:
    # enforcing - SELinux security policy is enforced.
    # permissive - SELinux prints warnings instead of enforcing.
    # disabled - No SELinux policy is loaded.
    SELINUX=permissive
    # SELINUXTYPE= can take one of these two values:
    # targeted - Only targeted network daemons are protected.
    # strict - Full SELinux protection.
    SELINUXTYPE=targeted
    ---

    After the change it is recommended to reboot the server.
     
  3. carpman

    carpman Guest

    0
     

    Hello and thanks for reply. selinux is not installed.

    Code:
    # cat /etc/selinux/config
    cat: /etc/selinux/config: No such file or directory
    
    Code:
    aptitude install selinux-utils
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initializing package states... Done
    Writing extended state information... Done
    Building tag database... Done
    The following packages are unused and will be REMOVED:
      autoconf automake automake1.4 autotools-dev gcc gcc-4.2 libgomp1 libltdl3 libltdl3-dev m4 shtool
    The following packages have been automatically kept back:
      bind9 libdns35 libisc35
    The following packages have been kept back:
      bind9-host dnsutils libbind9-30 libisccc30 libisccfg30 liblwres30 linux-image-2.6.24-24-server
    The following NEW packages will be installed:
      selinux-utils
    0 packages upgraded, 1 newly installed, 11 to remove and 10 not upgraded.
    Need to get 30.1kB of archives. After unpacking 9069kB will be freed.
    Do you want to continue? [Y/n/?] n
    Abort.
    
    cheers
     
  4. abezborodova

    abezborodova Guest

    0
     
    Could you specify where the error is shown?
     
  5. carpman

    carpman Guest

    0
     
    Hello, error came from /var/log/messages
     
  6. carpman

    carpman Guest

    0
     
    ok found culpret, ubuntu uses apparmor which like selinux, turned it off and bind works, just need to find a way allowing bind with apparmor now.
     
Loading...