1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

[bug?] Invalid base path

Discussion in 'Plesk for Windows - 8.x and Older' started by Armand, Jul 27, 2004.

  1. Armand

    Armand Guest

    0
     
    Just installed a copy of Plesk 7.0.. So much nicer than 6.5! :)
    All works fine except some of the file browse functions in the panel.

    When I click on Server -> Services -> Skeleton
    I get the following error
    Something to do with the filepath using backslash and slash in the same string? (I marked it with bold in the example error)

    a similar "Invalid base path." error also occures when I click Domains -> Hosting -> File Manager
     
  2. shwonder

    shwonder Guest

    0
     
    It seems that permissions on folder is not set correctly.
    1. login as administrator
    2. launch command line
    filemng root realpath "D:\sitedata\vhosts/.skel/0"
    if you see an error message, please post it here
     
  3. Armand

    Armand Guest

    0
     
    After executing your command I get this 3 line reply:

     
  4. SupermanInNY

    SupermanInNY Guest

    0
     
    I have the identical error.

    0: C:\Program Files\SWsoft\Plesk\admin\plib\class.Checker.php:568 psaerror(string "Invalid base path.")
    1: C:\Program Files\SWsoft\Plesk\admin\plib\class.FileManager.php:586 checker::filepath(string "C:/inetpub/vhosts/.skel/0", string "C:\inetpub\vhosts/.skel/0", string "root")
    2: C:\Program Files\SWsoft\Plesk\admin\plib\class.FileManager.php:744 filemanager->get_file_path(string "/")
    3: C:\Program Files\SWsoft\Plesk\admin\plib\class.cList.php3:69 filelist->fetchfilelist()
    4: C:\Program Files\SWsoft\Plesk\admin\plib\class.cList.php3:86 filelist->fetchlist()
    5: C:\Program Files\SWsoft\Plesk\admin\htdocs\server\skeleton.php:199 filelist->init()

    and identical output when entering the filemng root realpath "D:\sitedata\vhosts/.skel/0" command.
    In mycase it is


    filemng root realpath "c:\inetpub\vhosts/.skel/0"




    But the output is the same (with the correct path).

    -Alon.
     
  5. shwonder

    shwonder Guest

    0
     
    User psaadm should have permissions for full access to folder vhosts\.skel (c:\Inetpub\vhosts\.skel) and its childs. Please set them using Windows explorer (My Computer ...)
    I hope, some days later it will be FAQ available where most users and groups permissions will be listed.
     
  6. Armand

    Armand Guest

    0
     
    It does have full access, but still no luck... :(
     
  7. shwonder

    shwonder Guest

    0
     
    What about children objects?
    Click Advanced button and 'Replace ...'
    For .skel you can replace permissions. For some other directories it is better to click on every child and check 'Allow inheritance ...' check box.
     
  8. Armand

    Armand Guest

    0
     
    still not working :(
     
  9. shwonder

    shwonder Guest

    0
     
    ok. Try to create value under registry key
    HKEY_LOCAL_MACHINE\SOFTWARE\PLESK\PSA Config\Config
    name Debug
    type DWORD
    value 1

    Then try to access once again. Look at the EventsLog and try to find messages corresponding to problem. And post them here, please.

    Do you have Plesk support subscription?
     
  10. Armand

    Armand Guest

    0
     
    I added the 'Debug' key als told like so:

    [​IMG]

    I don't see extra messages appearing in the Event log though..

    The only two messages which are re-occuring are from source:
    "Plesk Miscellaneous Service"

     
  11. mmontgomery

    mmontgomery Guest

    0
     
    Solution

    For everyone having this issue, here is the solution:

    Open regedit

    Go to HKLM\SOFTWARE\Plesk\PSA Config\

    Right click on 'config' folder. Go to properties.

    Give 'Users' group permissions to read this folder.

    Hope this helps.
     
Loading...