1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can receive external mail !!!!

Discussion in 'Plesk for Linux - 8.x and Older' started by oldsand, Aug 29, 2006.

  1. oldsand

    oldsand Guest

    0
     
    I can't receive some external mail that send to my server. I check the logs of the qmail, but can't find the reject or block message. I have cancel all the MAPS and spam filters, but the problem still exist. Does anyone know how to solve this problem?
     
  2. jwdick

    jwdick Guest

    0
     
    Do you have a firewall blocking smtp? Does the person sending the external email receive an error message or a failure to deliver message?
     
  3. gddotts

    gddotts Guest

    0
     
    I have this same problem. Specifically from one domain (sai.state.ok.us).

    Problem: I can send messages to "someone@sai.state.ok.us" but when they reply it is not received on my side or bounced back on their side.

    I've worked with the other people and their log files show a successful connect and delivery. I've checked the log files on my side (/usr/local/psa/var/log/maillog ) but the only entry is where I sent an email out to that domain - nothing for the receipt of mail in from the other side.

    Any thoughts or suggestions?
     
  4. jwdick

    jwdick Guest

    0
     
    Are emails from other sources getting through to your domain?
     
  5. gddotts

    gddotts Guest

    0
     
    We finally sorted this out just a while ago. Turns out to be a two part problem.

    Part 1: Our server had an expired TLS certificate (/var/qmail/contol/servercert.pem).

    Part 2: The sending server was configured to abort connections and queue the message when connecting to servers that advertise STARTTLS and have TLS errors (i.e expired certificate).

    Troubleshooting: To diagnose this problem I grep'ed "/usr/local/psa/var/log/maillog" for the IP address of the sending server. No luck there. Then I grep'ed "/var/log/secure" for the IP address of the sending server and found repeated connection attempts at 3 - 4 minute intervals. Finally, a little digging by the guys on the sending side discovered a "454 TLS missing certificate possible esmtp incompatibilities..." error in their logs.

    Solution: Renewed the servercert.pem and problem solved. :D

    To answer your question, yes we were receiving mail from all other sources. At least none of our customers reported not being able to receive mail from anyone.

    Thanks for the reply.
     
  6. ewtech

    ewtech Guest

    0
     
  7. jcalegre

    jcalegre Guest

    0
     
    Hi!
    How have you renewed servercert.pem?

    Tx!

    Jorge Alegre
     
Loading...