1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Cannot Log into Control Panel after Upgrade

Discussion in 'Plesk for Linux - 8.x and Older' started by rooky, Oct 25, 2005.

  1. rooky

    rooky Guest

    0
     
    Hello,
    I recently upgraded from v7.5.2 to v7.5.3 and cannot access the Plesk Control Panel at https://example.com:8443, it returns a 404 error. I am with Godaddy and they want to charge $100+ to fix it. The reason I upgraded was because I wanted to install the back up utilities but had to install the v7.5.3 Base Package as well. After selecting the Back Up Utilities, the installation started, about 10 minutes later I receive an email from the server saying 'Update of system was failed for some reason.' with a complete log of the process. After this, I have been unable to login to Plesk.

    Part of the email had this at the end:


    ===> Installing psa database
    Trying to check psa database... Trying to find psa database...

    ERROR while trying to mysql datadir not found
    Check the error reason(see log file: /tmp/psa_7.5.3_RedHat_9_build75050506.13_upgrade.log), fix and try again

    Aborting...

    error: %post(psa-7.5.3-rh9.build75050506.13) scriptlet failed, exit status 1
    Generate public/private keys pair for server ...
    Server keys generating done

    ----- end of output -----
    ===> Autoinstaller: stopped logging at Tue Oct 25 06:02:39 2005

    ***** end of log file *****



    My question is there anyone that would know what the problem would be and is there a fix I can apply myself.
    TIA for any help.
    Wayne
     
  2. manarak

    manarak Guest

    0
     
    well, what does /tmp/psa_7.5.3_RedHat_9_build75050506.13_upgrade.log say?
     
  3. rooky

    rooky Guest

    0
     
    Hi, thanks for the reply, here is a copy of upgrade.log

    Trying to set up default qmail permissions... done

    ===> Installing Qmail server
    Trying to set maillog file to /usr/local/psa/var/log/maillog... done
    Configuring Qmail...
    Trying to generate SSL certificates for TLS sessions... done
    Trying to register service qmail... using /sbin/chkconfig
    done
    Trying to register qmail in alternatives... done
    Trying to start Qmail services... Starting qmail: [ OK ]^M
    done
    Trying to define super-server internet daemon type... xinetd
    Trying to check if xinetd daemon is running... done


    START LOGGING: Tue Oct 25 06:01:22 MST 2005
    Trying to stop MySQL server... Stopping MySQL: [ OK ]^M
    done
    mysqld (pid 24943 481 388 323 31394 31364 31329 31296 31265 30464) is running...
    mysqld is stopped
    Making some checks before upgrading

    Now BIND server shutting down...

    Trying to stop BIND server... Stopping named:
    done
    Trying to start BIND server... Starting named: done

    BIND server starts Ok.

    Trying to start MySQL server... Starting MySQL: [ OK ]^M
    done
    Trying to establish test connection... connected
    mysqld (pid 31968 31937 31905 31874 31777 31752 31715 31648 31619 31523) is running...
    Trying to stop MySQL server... Stopping MySQL: [ OK ]^M
    done
    mysqld (pid 1921 31937 31905 31874 31777 31752 31715 31648 31619 31523) is running...
    mysqld is stopped

    ===> Checking for the necessary system accounts
    Checking for the system groups and users necessary for Qmail...
    Checking for the group 'nofiles'...
    Group 'nofiles' already exists

    Checking for the user 'alias'...
    User 'alias' already exists

    Checking for the user 'qmaild'...
    User 'qmaild' already exists

    Checking for the user 'qmaill'...
    User 'qmaill' already exists

    Checking for the user 'qmailp'...
    User 'qmailp' already exists

    Checking for the group 'qmail'...
    Group 'qmail' already exists

    Checking for the user 'qmailq'...
    User 'qmailq' already exists

    Checking for the user 'qmailr'...
    User 'qmailr' already exists

    Checking for the user 'qmails'...
    User 'qmails' already exists

    Checking for the group 'popuser'...
    Group 'popuser' already exists

    Checking for the user 'popuser'...
    User 'popuser' already exists

    Checking for the system groups and users necessary for MySQL...
    Checking for the group 'mysql'...
    Group 'mysql' already exists

    Checking for the user 'mysql'...
    User 'mysql' already exists

    Checking for the system groups and users necessary for admin server...
    Checking for the group 'psaadm'...
    Group 'psaadm' already exists

    Checking for the user 'psaadm'...
    User 'psaadm' already exists

    Checking for the system groups and users necessary for Apache...
    Checking for the group 'apache'...
    Group 'apache' already exists

    Checking for the user 'apache'...
    User 'apache' already exists

    Checking for the group 'psaftp'...
    Group 'psaftp' already exists

    Checking for the user 'psaftp'...
    User 'psaftp' already exists

    Checking for the group 'psaserv'...
    Group 'psaserv' already exists

    Checking for the group 'psaserv'...
    Trying to add supplementary group 'psaserv' for user 'apache'... done
    done
    Checking for the group 'psaserv'...
    Trying to add supplementary group 'psaserv' for user 'psaftp'... already there
    Checking for the group 'psaserv'...
    Trying to add supplementary group 'psaserv' for user 'psaadm'... already there
    group psacln already exists
    /usr/local/psa/bin/chrootsh already registered as a login shell
    Trying to start MySQL server... Starting MySQL: [ OK ]^M
    done
    Trying to establish test connection... connected
    `/var/lib/psa/dumps/mysql.preupgrade.dump.gz' -> `/var/lib/psa/dumps/mysql.preupgrade.dump.gz.1'
    Trying to backup MySQL database... done
    MySQL databases are dumped to /var/lib/psa/dumps/mysql.preupgrade.dump.gz
    Setting the default locale
    The default locale is set to en-US (ENGLISH, UNITED STATES)

    START LOGGING: Tue Oct 25 06:02:32 MST 2005


    ===> Installing rbash
    Checking that /bin/rbash registered as login shell...
    /bin/rbash
    /bin/rbash is already registered as login shell

    ===> Installing psa database
    Trying to check psa database... Trying to find psa database...

    ERROR while trying to mysql datadir not found

    Aborting...
     
  4. manarak

    manarak Guest

    0
     
  5. rooky

    rooky Guest

    0
     
    Would it have to do with this?

    ===> Installing psa database
    Trying to check psa database... Trying to find psa database...

    ERROR while trying to mysql datadir not found

    Aborting...
     
  6. rooky

    rooky Guest

    0
     
    Failed Again

    Well no one knew how to fix this problem so I purchased a new sever from Godaddy and did the Plesk update from v7.5.3 to v7.5.4....and yes it FAILED!! Can't log onto the Control Panel, what a complete waste of time Plesk is...and MONEY!! Do these people know what they are doing? Now I have to find a new host that doesn't use Plesk...more wasted time and money.
     
Loading...