1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Cannot log into Plesk control panel - completely out of the blue!

Discussion in 'Plesk for Linux - 8.x and Older' started by atomicguava, Nov 6, 2007.

  1. atomicguava

    atomicguava Guest

    0
     
    Hi, I found the below thread in Google:

    http://forum.swsoft.com/showthread.php?s=&threadid=19632

    I reposted it here because I'm experiencing it in Plesk 8.2.1

    Whenever I try to log into the control panel in a browser, I get the below message:

    The Plesk 7.1 thread I found above mentioned duplications of PHP.ini so I've tried to find all the locations of PHP.ini by executing the following in SSH:

    Which returns:

    So I tried renaming the .ini which is in the PSA/admin/conf folder and restarting apache, but to no avail.

    I've tried running the command line autoinstaller, but all that wants to do is install a Battlefield2 module! Is there a way to reapply Plesk 8.2.1 - I think something has corrupted...

    I don't really want to re-image - is there anything else anyone can suggest? I'm still unable to log in, but services work as normal.

    Incidentally, the permissions for the file in question are:

    Thanks in advance.
     
  2. DmitryT

    DmitryT Guest

    0
     
    Normally Plesk is using its own php with the configuration file located in /usr/local/psa/admin/conf/php.ini. So, you need just to make sure that the following directories are specified in the include path of php.ini:

    $ cat /usr/local/psa/admin/conf/php.ini | grep -i include_path
    include_path = "/usr/local/psa/admin/plib:/usr/local/psa/admin/javascripts:/usr/local/psa/admin/plib/locales:/usr/local/psa/admin/auto_prepend:/usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin:/usr/local/psa/admin/htdocs/domains/databases/phpPgAdmin"

    Do not forget to restart apache service for changes to take effect:

    # /etc/init.d/httpd restart
    # /usr/local/psa/admin/bin/websrvmng -a -v
     
  3. anb_t

    anb_t Guest

    0
     
    Plesk is distributed with its own apache and php that do not affect original system php and apache. Plesk apache and php serve Plesk control panel, system php and apache serve websites.
    Plesk apache and php are included into the base Plesk package:

    [root@weather ~]# rpm -q psa
    psa-8.2.1-fc4.build82070918.10

    [root@weather ~]# rpm -ql psa-8.2.1-fc4.build82070918.10 | grep -E 'bin/php$|bin/httpsd$'
    /usr/local/psa/admin/bin/httpsd
    /usr/local/psa/admin/bin/php
    [root@weather ~]#
    [root@weather ~]# /usr/local/psa/admin/bin/php -v
    PHP 5.0.5 (cli) (built: Sep 18 2007 10:23:07)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v2.0.5, Copyright (c) 1998-2004 Zend Technologies
    with eAccelerator v0.9.3, Copyright (c) 2004-2004 eAccelerator, by eAccelerator
    [root@weather ~]#
    [root@weather ~]# /usr/local/psa/admin/bin/httpsd -v
    Server version: Apache/1.3.33 (Unix)
    Server built: Sep 18 2007 10:24:09
    [root@weather ~]#

    Plesk apache and Plesk php configuration files:

    [root@weather ~]# rpm -ql psa-8.2.1-fc4.build82070918.10 | grep -E 'php.ini$|httpsd.conf$'
    /usr/local/psa/admin/conf/httpsd.conf
    /usr/local/psa/admin/conf/php.ini
    [root@weather ~]#

    System apache (client apache) and php serve clients web pages:

    [root@weather ~]# rpm -q php php-5.0.4-10.5
    [root@weather ~]# rpm -q httpd httpd-2.0.54-10
    [root@weather ~]# rpm -ql php | grep bin/php$
    /usr/bin/php
    [root@weather ~]# rpm -ql httpd | grep bin/httpd$
    /usr/sbin/httpd
    [root@weather ~]#

    [root@weather ~]# /usr/bin/php -v
    PHP 5.0.4 (cli) (built: Nov 8 2005 08:27:12)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v2.0.4-dev, Copyright (c) 1998-2004 Zend Technologies
    with the ionCube PHP Loader v3.1.16, Copyright (c) 2002-2006, by ionCube Ltd., and
    with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.3.0, Copyright (c) 1998-2007, by Zend Technologie
    [root@weather ~]#
    [root@weather ~]# /usr/sbin/httpd -v
    Server version: Apache/2.0.54
    Server built: May 23 2005 08:12:24
    [root@weather ~]#

    I know that it is not recommend to change Plesk apache and php configuration, this might broke the panel, I guess this has happened in your case. On the other hand you are free to reconfigure client apache and php as you wish.

    What I offer you to do is reinstall main Plesk package forcibly.

    to verify its consistency:
    ~# rpm -V psa

    and reinstall:
    ~# rpm -Uvh --force /PATH/TO/PACKAGE/psa-8.2.1-fc4.build82070918.10.i586.rpm

    The error about missing 'auth.php3' related to Plesk document root:

    $PRODUCT_ROOT_D/admin/htdocs

    Value of PRODUCT_ROOT_D is set in Plesk configuration file /etc/psa/psa.conf.

    Also I recommend you to disable SELinux if it is in enforcing mode.

    ~# grep SELINUX= /etc/selinux/config

    Hope this helps.

    ./anb
     
Loading...