1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Cannot Log Into Webmail

Discussion in 'Plesk for Linux - 8.x and Older' started by xplatform12, Jan 26, 2007.

  1. xplatform12

    xplatform12 Guest

    0
     
    I recently have HSPC setup with Linux Virtuozzo/Plesk. I am setting up Plesk Clients with domains. Everything appears to be working except for webmail.

    I can send email to the new domains and pop the mail off the new domains. I can even see the users mail directory from within Plesk to Train spamassassin.

    If I go to webmail.domainname.com I do get the Horde login, but am unable to login with either user@domainname.com or user with the correct password. It keeps telling me Login Failed.

    This is on a name based domain hosting account. Does anyone have any idea what may be wrong or what I should check?
     
  2. beta_briandelicata

    beta_briandelicata Guest

    0
     
    Same issue here. I edited /etc/psa-horde/imp/servers.php and included my ip address as described in another entry but it still does not work.
     
  3. tnats@

    tnats@ Guest

    0
     
    There is another post in this forum about this.

    Once I added this to /etc/hosts, it worked fine:

    127.0.0.1 <mydomain> localhost localhost.domain
     
  4. beta_briandelicata

    beta_briandelicata Guest

    0
     
    Tried all options after I searched the forum. My etc/hosts is currently showing as:

    127.0.0.1 localhost localhost.domain
    127.0.0.1 as.<mydomain> as
     
  5. Beto

    Beto Guest

    0
     
    I had the same problem after an upgrade and asked sw-soft to help. They did the following:

    Change "session.auto_start = 1" in /etc/php.ini

    maybe you should check this??
     
  6. tnats@

    tnats@ Guest

    0
     
    If the php.ini trick doesn't work, send us your mail.err logs.
     
  7. blank_page

    blank_page Regular Pleskian

    24
    53%
    Joined:
    Dec 17, 2006
    Messages:
    229
    Likes Received:
    0
    Hi,

    127.0.0.1 as.<mydomain> as not good.

    main_ip as.<mydomain> as is good.

    So your hosts file should be like this:

    127.0.0.1 localhost localhost.domain
    xxx.xxx.xxx.xxx as.<mydomain> as
     
  8. beta_briandelicata

    beta_briandelicata Guest

    0
     
    Edited etc/hosts as per blank_page and php.ini and is still not working.

    I am getting this in my messages log and the mailbox/server exists:

    Jan 27 13:12:48 as wdcollect[27907]: Connection to server has been established.
    Jan 27 13:12:52 as wdcollect[27907]: SMTP server error: '550 sorry, no mailbox here by that name. (#5.7.17)^M'
    Jan 27 13:12:52 as wdcollect[27907]: SMTP server refused recieving e-mail with subject 'IMAP/POP3 Server (Courier-IMAP) on as.<mydomain.com> has been released from monitoring', the e-mail is discarded.
    Jan 27 13:13:59 as wdcollect[27907]: Connection to SMTP server has been closed.
     
  9. tnats@

    tnats@ Guest

    0
     
  10. beta_briandelicata

    beta_briandelicata Guest

    0
     
    Telnet to port 110 works, does not work on imap port (Connection refused). Webmail still does not work - any other ideas?

    [Edit - Output when I run ps ax | grep courier]

    telnet: connect to address 127.0.0.1: Connection refused
    [root@as lib]# ps ax | grep courier
    1724 ? S 0:00 /usr/lib/courier-imap/couriertcpd -address=0 -stderrlogger=/usr/sbin/courierlogger -stderrloggername=pop3d -maxprocs=40 -maxperip=4 -pid=/var/run/pop3d.pid -nodnslookup -noidentlookup 110 /usr/sbin/pop3login /usr/lib/courier-imap/authlib/authpsa /usr/bin/pop3d Maildir
    1726 ? S 0:00 /usr/sbin/courierlogger pop3d
    1737 ? S 0:00 /usr/lib/courier-imap/couriertcpd -address=0 -stderrlogger=/usr/sbin/courierlogger -stderrloggername=pop3d-ssl -maxprocs=40 -maxperip=4 -pid=/var/run/pop3d-ssl.pid -nodnslookup -noidentlookup 995 /usr/bin/couriertls -server -tcpd /usr/sbin/pop3login /usr/lib/courier-imap/authlib/authpsa /usr/bin/pop3d Maildir
    1739 ? S 0:00 /usr/sbin/courierlogger pop3d-ssl
    11764 pts/0 S+ 0:00 grep courier
     
  11. tnats@

    tnats@ Guest

    0
     
    I mean telnet to port 25 to see if that is a valid username.

    telnet yourbox 25

    ehlo,etc..

    This way you take qmail out of the equation. From there, you need to try to connect to your imap server without using webmail. ie. thunderbird, outlook
    If you can connect there, then it's a Horde issue.

    Also, copy and paste your /etc/hosts file here again.
     
  12. beta_briandelicata

    beta_briandelicata Guest

    0
     
    Results if I telnet to port 25:

    [root@as /]# telnet localhost (also tried my ip instead of localhost) 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 as.mydomain.com ESMTP
    user someone@mydomain.com
    502 unimplemented (#5.5.1)

    Meanwhile pop3/smtp works via an external client.

    /etc/hosts

    127.0.0.1 localhost localhost.domain
    <my ip address> as.mydomain.com as
    ~
     
  13. tnats@

    tnats@ Guest

    0
     
    See that 250 at the bottom, are you getting that if you try what I typed below?


    plesk1:/var/log# telnet localhost 25
    Trying 127.0.0.1...
    Connected to plesk1.redrocksdatacenter.com.
    Escape character is '^]'.
    220 plesk1.redrocksdatacenter.com ESMTP
    ehlo t10.net
    250-plesk1.redrocksdatacenter.com
    250-STARTTLS
    250-PIPELINING
    250 8BITMIME
    mail from:tn@t10.net
    250 ok
    rcpt to:tom.nats@redrocksdatacenter.com
    250 ok
     
  14. beta_briandelicata

    beta_briandelicata Guest

    0
     
    yes I am - all ok
     
  15. tnats@

    tnats@ Guest

    0
     
    Damn, I'm sorry I'm not helping you. Everything else works except Horde login correct?
     
  16. beta_briandelicata

    beta_briandelicata Guest

    0
     
    Horde and Imap are now working - and thanks for your support!
     
  17. tnats@

    tnats@ Guest

    0
     
    Wait, what did you do?
     
  18. beta_briandelicata

    beta_briandelicata Guest

    0
     
    Followed your steps. Pop3/smtp is working via telnet and external client. Still getting a login Failed in webmail and imap is not working.
     
  19. xplatform12

    xplatform12 Guest

    0
     
    He didn't actually get it working. The original thread has to do with not being able to login. I have done everything stated in this thread and still cannot log into webmail.

    I think the problem has something to do with horde and imap. I did find a test file that was installed on the server when in installed the application tempaltes. It is:

    http://webmail.<domainame>.com/imp/test.php

    When I ran that, there was a place to put in the imap info to test. I put in the following:

    Server: localhost
    Port: <left blank>
    Username: <entered email of know user>
    Password: <entered users password>
    Server Type: IMAP

    I then submitted the test and got some good results:

    -------------------------------

    PHP Mail Server Support Test
    Attempting to automatically determine the correct connection parameters for your server:

    * Trying protocol imap/notls, Port 143:

    SUCCESS - INBOX has 2 messages (0 new 0 recent)

    * Trying protocol imap/ssl, Port 993:

    ERROR - The server returned the following error message:

    Certificate failure for localhost: self signed certificate:
    /C=US/ST=NY/L=New York/O=Courier Mail Server/OU=Automatically-generated
    IMAP SSL key/CN=localhost/emailAddress=postmaster@example.com

    * Trying protocol imap/ssl/novalidate-cert, Port 993:

    SUCCESS - INBOX has 2 messages (0 new 0 recent)

    * Trying protocol imap/tls/novalidate-cert, Port 143:

    ERROR - The server returned the following error message:

    Unable to negotiate TLS with this server

    The following configurations were successful and may be used in your imp/config/servers.php file:

    Configuration 1

    'server' => 'localhost'
    'protocol' => 'imap/notls'
    'port' => '143'

    Configuration 2

    'server' => 'localhost'
    'protocol' => 'imap/ssl/novalidate-cert'
    'port' => '993'

    The following IMAP server information was discovered from the remote server:

    Namespace Information

    NAMESPACE: "INBOX."
    DELIMITER: .
    TYPE: personal

    NAMESPACE: "#shared."
    DELIMITER: .
    TYPE: shared

    NAMESPACE: "shared."
    DELIMITER: .
    TYPE: shared


    IMAP CHILDREN support:

    SUPPORTED

    IMAP Charset Search Support:

    Server supports searching with the UTF-8 character set.


    -------------------------------------------


    Looking at the results, the test.php page from within horde did see imap running on port 143 and even found the user has 2 email messages in thier box. So the test.php page is working

    I also checked and made sure that servers.php did have the 3 lines listed in configuration1 above.

    The following if from servers.php

    --------------------------------

    $servers['_prompt'] = array(
    'name' => _("Choose a mail server:")
    );

    // get hostname from http URL (patch for Plesk)
    $headers = getallheaders();
    $ServerName = preg_replace('/^webmail\./', '', preg_replace('/^www\./', '', $headers['Host']));
    $DomainName = ($ServerName != '') ? $ServerName : '@DEFAULT_SERVERNAME@';

    $servers['imap'] = array(
    'name' => 'IMAP Server',
    'server' => 'localhost',
    'hordeauth' => false,
    'protocol' => 'imap/notls',
    'port' => 143,
    'maildomain' => $DomainName,
    'smtphost' => 'localhost',
    'smtpport' => 25,
    'realm' => '',
    'preferred' => '',
    );

    ------------------------------------

    I am curious if there is something in php.ini that may prevent php from getting some of the headers that are required for in the code. Does anyone know what php.ini variable may prevent that?

    Any ideas at this point would be good.
     
  20. xplatform12

    xplatform12 Guest

    0
     
    I found why it was not working for me. I was correct in my assumption that it was a php problem. I looked in /etc/ and found a couple backup php.ini files that the system must have created. I copied the php.ini to a backup file and then copied the oldest php.ini backup file to php.ini, restarted httpd and viola, I can now log in to Horde.

    So I put the original php.ini file back that didn't work and compared it to the one that did work. I found that there was 1 setting that needed to be changed.

    Look for:

    session.auto_start = 1

    and change it to:

    session.auto_start = 0

    restart httpd and see if you can login. This allowed me to get in. I also did a little searching and found this online:

    http://www.phpfreaks.com/phpmanual/page/ref.session.html

    The main part of that doc that you should read is:

    ----------------------------------

    The session support allows you to register arbitrary numbers of variables to be preserved across requests. When a visitor accesses your site, PHP will check automatically (if session.auto_start is set to 1) or on your request (explicitly through session_start() or implicitly through session_register()) whether a specific session id has been sent with the request. If this is the case, the prior saved environment is recreated.

    Caution

    If you do turn on session.auto_start then you cannot put objects into your sessions since the class definition has to be loaded before starting the session in order to recreate the objects in your session.

    -----------------------------------

    I have not tried other things on the server that require php, so I am not sure of the full implications if this will cause problems with other things or not. However, I can use Horde now.
     
Loading...