• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Cannot receive any email after upgrade

G

Gipi81

Guest
This is my problem:
After a 7.5.3 -> 7.5.4 upgrade i cannot receive any email to my server ( and to all domains i host).
I check the log file /usr/local/psa/var/log/maillog and i see this error:
qmail: 1128028007.870364 delivery 6: failure: Sorry._Although_I'm_listed_as_a_best-preference_MX_or_A_for_that_host,/ it_isn't_in_my_control/locals_file,_so_I_don't_treat_it_as_local._(#5.4.6)/
and this...
qmail: 1128027997.909214 delivery 4: failure: Sorry,_I_couldn't_find_any_host_named_myhostname._(#5.1.2)/


Any help? thanks
 
Restore the old copy of

/var/qmail/control/rcpthosts

it should contain one line per domain, each line is the domain.tld which are hosted.

Sounds like the upgrade must have corrupted or wiped out the contents.
 
OK it is solved!
I have re-installed psa-qmail* and set the config files into directory /var/qmail/control and now it work.
But there is a new problem..
After re-install i see this message for old domain names contains in my hosting:

Sep 30 09:54:37 main qmail: 1128066877.674406 delivery 22: deferral: Unable_to_chdir_to_maildir._(#4.2.1)/

For domains created after this re-install, Qmail work properly and not get any problem.
There is a conflict for chmods?

Thanks
 
Sounds like either ownership (chown) or permissions (chmod) may be messed up.

Compare the ownership and perms of the Maildirs created after (working) and those from before (not working).
 
Back
Top