1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Cannot restore, unknown error code from backup_sign utility

Discussion in 'Plesk for Linux - 8.x and Older' started by stoilis, Oct 23, 2007.

  1. stoilis

    stoilis Guest

    0
     
    Hi,

    I am using Plesk 8.2.1 on Debian etch, using the latest updates on anything.

    While trying to create a map file on a new server for restoration, I get the following error:

    # pleskrestore --create-map backupfile -map map
    Can't check backup file: unknown error code from backup_sign utility: 255
    #

    The error appears only after a while, about an hour of processing the backup file.

    What is probably useful to mention, is that my backup is split at 2GB chunks. So, backupfile is just the first one, the whole list being:
    -rw-r--r-- 1 root root 2146435072 2007-10-23 14:04 backupfile
    -rw-r--r-- 1 root root 2146435072 2007-10-23 14:09 backupfile.001
    -rw-r--r-- 1 root root 2146435072 2007-10-23 14:14 backupfile.002
    -rw-r--r-- 1 root root 2146435072 2007-10-23 14:19 backupfile.003
    -rw-r--r-- 1 root root 2146435072 2007-10-23 14:24 backupfile.004
    -rw-r--r-- 1 root root 1173101133 2007-10-23 14:26 backupfile.005

    Any hint on how to proceed to restoration?

    Thank you in advance.
     
  2. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
    You should consider this as per SWSoft Knowledgebase article:

    http://kb.swsoft.com/en/2279

    RESOLUTION
    Such error can be caused by missing certificate for backup signing. Try to generate the certificate with the command:

    # $PRODUCT_ROOT_D/admin/sbin/backup_sign generate

    Our symptoms were different. We got:

    backup_sign: Can't find private key in database:
    backup_sign: Can't get server's private key
    23:17:23 ERROR Failed to create MIME message

    Our backups were still completed, and the normal sizes were there, and even looking at the file it seemed intact, but every time we tried to create a map or restore something we got a backup corrupted message. The above Knowledgebase article sorted us out!
     
  3. stoilis

    stoilis Guest

    0
     
    I solved the problem by generating the map file on the original server. There, it could be generated without a problem.
     
Loading...