• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Cannot use index.php in mod_rewite

Kroptokin

Regular Pleskian
I've just migrated a domain to a new server. From CentOS 6.5 to Centos 7.2

Mostly it has gone pretty well. But in one domain I am unable to use index.php in mod_rewrite.

This is the .htaccess file:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

With this configuration I get the default 'Welcome to Plesk' page. I also see Got error 'Primary script unknown' in the error logs, which may or may not be related.

If I change index.php to (say) home.php everything works as expected.

So. There is some specific configuration issue with index.php.

I tried switching from running PHP as FPM to FastCGI as some threads seem to suggest that as a possible solution but that didn't help.

Does anyone have any ideas?
 
RESOLVED.

Stupid error. index.html was present in the directory. It looks like there must be a DirectoryIndex directive somewhere to serve index.html if it exists.
 
Back
Top