1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Can't Change Permissions after 7.5.5 Upgrade

Discussion in 'Plesk for Windows - 8.x and Older' started by mikelegg, Dec 5, 2005.

  1. mikelegg

    mikelegg Guest

    0
     
    I recently upgraded to 7.5.5, now none of my users (clients, domain users, or admin) can change folder permissions via the Plesk File Manager. We get this error ....

    FileManager::get_file_info_wrapper() failed: filemng util failed: Unable to lookup name for SID: (1332) No mapping between account names and security IDs was done.
    ---------------------- Debug Info -------------------------------
    0: C:\Program Files\SWsoft\Plesk\admin\htdocs\domains\webdirs\webdir_permissions.php:43 psaerror(string "FileManager::get_file_info_wrapper() failed: filemng util failed: Unable to lookup name for SID: (1332) No mapping between account names and security IDs was done.")

    I logged a support job yesterday, but so far I haven't heard anything. Has anyone else had this problem?
     
  2. vekna

    vekna Guest

    0
     
    It can 2 causes
    1. Bad SID on your server - it Windows problem (contact with Microsoft)
    2. Incorrect permission on your server - You should use reconfigurator - Repair Plesk installation - Vhost check. To repair it.
     
  3. mikelegg

    mikelegg Guest

    0
     
    Thanks vekna

    I found I had to run "Plesk File Security" first, then run "Plesk Virtual Hosts Security" and it temporarily fixed the problem.

    I ran them a second time and seems to be OK now.
     
  4. ZeusChicago

    ZeusChicago Guest

    0
     
    I had the above, on the second day of use, on a fresh server.
    The only things of note that I did was

    Change the virtualhost location to another drive
    Applied OS patches
    Applied Plesk patches

    What I finally noticed was that after the patches were applied, the virtualhost location was reset to my C Drive again (ugg)

    Z
     
  5. swarm

    swarm Guest

    0
     
    It seems you've done changing vhosts location manually and that is the cause of your problems.
    So you should stop IIS and rename your vhosts folder to something else to avoid data loss.
    Then use Plesk Reconfigurator utility to change vhosts location. After this will be done, copy backed vhosts folder to new place and then use Plesk Reconfigurator to fix vhosts permissions with marking 'Plesk Virtual Hosts Security' at 'Repair Plesk Configuration' menu.
     
  6. ZeusChicago

    ZeusChicago Guest

    0
     
    Accually, I did change it with the Plesk Reconfigurator utility, and then setup like 10 sites which all worked fine. I then applied the patch, rebooted and went to add another site and noticed It was not getting created on D:\ anymore and started seeing the above errors.

    It took me a bit before I went and checked out my C drive again and found it had created the lastest new site there.

    My problems were solved by moving it back with Plesk Reconfigurator utility and then following mikelegg suggestion :cool:

    Z
     
Loading...