1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can't open data connection

Discussion in 'Plesk for Windows - 8.x and Older' started by Alex K., Apr 29, 2009.

  1. Alex K.

    Alex K. Guest

    0
     
    Hello,

    My server is a Windows 2008 machine with Plesk 8.6
    It seems that there's an issue with the FTP service.

    Upon login (using passive mode) i get:

    Response: 425 Can't open data connection.
    Error: Failed to retrieve directory listing

    I checked the passive port range in Plesk and is set to 1025-5000

    I also noticed this message on Plesk:

    "Information: Warning: due to active Windows Firewall and Windows Application Layer Gateway Service (ALGS) not allowing to use a custom passive FTP ports range, it is recommended to switch ALGS off. If ALGS service is switched on, passive FTP ports range will be set to default 5001-65535, ignoring any custom values. Refer to Microsoft Windows help files for the information on how to switch ALGS off."

    ALGS is indeed off on the machine.
    Though, i still get the error.

    Any ideas?

    I have not changed the windows firewall rules.

    Thank you
    A.
     
  2. voobrajulka ya

    voobrajulka ya Guest

    0
     
    Hello,

    Alex, have you tried to temporary disable Windows firewall and check if it helps or not?
     
  3. GabS

    GabS Guest

    0
     
    Hi Alex,

    yes you can test it by disabling firewall as may be ports are not added in Exception list.
    If you want to keep firewall enabled then you need to add FTP ports in Exception list.
    Also if you have used any other port other than default port then make sure you use correct port accordingly while FTPing.
    To check port availability you can execute following command on the command prompt of your local machine from which you are trying to FTP :-

    telnet serverIP port

    where serverIP is the IP address of your FTP server and port is that port that you have assigned to FTP service

    Hope this helps you :)

    Regards,
    sysadmin
     
    Last edited by a moderator: Jul 29, 2011
  4. MohammedA

    MohammedA Guest

    0
     
Loading...