• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Resolved Can't run php exec funtion on plesk running FastCGI application served by Apache

davilson18

New Pleskian
Hello, I'm new in Plesk.
I'm dealing with issue about php funtion executive bash script like : shell_exec(), exec(), passthru(),...It always show error :"permission denied" when I config php setting "run php as FastCGI application served by Apache". But after I set php setting to "run php as FPM application served by nginx", php funtion above run perfectly. Anyone know why?
ps: php version : 5.6.30
 
I've had this issue and finally solved it reinstalling ffmpeg to a shared location. I happened to install it with 'root' user and followed this installation guide: CompilationGuide/Centos – FFmpeg
As 'root' user, the library installed at $HOME='/root/'. No problem for terminal commands. But problem for PHP because the user is not 'root' but 'apache' or 'httpd' or 'nginx'... and it has not permissions.
Solution: reinstall following that guide, but instead of '$HOME', using '/usr/local'. Now both terminal and php can access it with different users.

Yes, shell's access can be limited via php.ini. "open_basedir" for instance can do exactly that, and it is for security reasons.
 
Back
Top