1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can't set permissions on an ../Upload folder for use with ASP.NET

Discussion in 'Plesk for Windows - 8.x and Older' started by Anim, Feb 18, 2006.

  1. Anim

    Anim Guest

    0
     
    Hi All

    I am trying to crete an uploads folder to be used in an ASP.NET application and having great difficulty in getting the write permissions set correctly via plesk or directly via a remote desktop session.

    I have tried adding read/write permissions to the IUSR_domain account via plesk.

    I have also tried adding the ASPNET account to this folder via permissions from windows explorer.

    No matter what I do my asp application says it has been denied access to write to this folder and its getting really frustrating.

    Also, whenever I try and add permission via plesk they seem to get reset or plesk adds a duplicate entry (under advanced) that resets the permissions to just read only.

    I also turned off the "Allow inheritable permissions...." check box.

    So, can anybody give me a step by step on how to create an /uploads folder within a website so that an ASP.NET 2.0 application can write files to it?

    Any help would be much appreciated.

    Regards
    Anim
     
  2. Gris@

    Gris@ Guest

    0
     
    you should give permissions to Network Service.
     
  3. Anim

    Anim Guest

    0
     
    Hi Gris

    I forgot to mention that I tried that initially without much luck too.

    File Explorer, right click uploads folder, properties, security tab, add, advanced, find now, selected NETWORK SERVICE and gave it read+write, apply. ok

    Tested web app, same error. "access denied"

    I noticed that the folder is flagged as read only (check box in properties) and if i deselect that then something else sets it to read only again straight away.

    Thanks
    Anim
     
Loading...