1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

CBM Login

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by RickR, Mar 14, 2011.

  1. RickR

    RickR Guest

    0
     
    I have a fresh or new install of Plesk Panel with Customer Billing Mgr. The first time I log into CBM I received an error about some SQL syntax. I finished the CBM configuration and went back to Plesk Panel and then clicked on the CBM Accounting link in the Plesk Panel and I received the same error message. I have attached a screen shot of that error.

    Error: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near


    I'm also getting a warning:
    Warning: The connection to the SSO server failed. You can try to log in to Customer & Business Manager using the local (non-SSO) method or try once againg with SSO.


    I searched the Forums for errors on CBM login and found nothing. What do I need to do to fix this "SQL syntax" issue? Is this a 'bug' in CBM for windows?

    This is installed on Windows 2008 R2 Web Edition. I have SQL Express installed but it is not being used by Plesk yet.
     

    Attached Files:

  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Try to rebuild SSO settings as it is described in http://kb.odin.com/en/9509
    You can find other useful articles about SSO for Plesk 10.x for Windows there. It maybe useful.
     
  3. PavelV

    PavelV Plesk for Windows Staff Member

    28
     
    Joined:
    Nov 15, 2010
    Messages:
    251
    Likes Received:
    15
    Need more info. Please look at %plesk_dir%\admin\logs\sso.log in order to get sql query with error.

    p.s. This issue can be related to IPv6. Is your hostname resolved to IPv6 address? If yes, then CBM and Plesk and SSO will try to create session for IPv6 and will fail.
     
  4. RickR

    RickR Guest

    0
     
    I have turned off Ipv6. It has been turned off since I installed the OS.

    I've attached the sso.log. The only log information in here is logging into Plesk and then clicking on one of the Billing links in Plesk. The error appeared as described and then I closed the browser.
     

    Attached Files:

  5. RickR

    RickR Guest

    0
     
    KB Article does not help

    Igor,

    Your advice did not help and I'm actually in worst shape. I followed the instructions - edited database, and detached Admin and Customer. When I went to edit the config file the values that the KB article suggests are not present. When I tried to "enable" admin I get an error and the information is stored in the sso.crash.log. I can't find this crash log! I rebooted thinking that a reboot would reset everything. I was wrong! I tried to log into the panel and I now get an error:

    Error: Unable to log you on. An internal error occurred in the Single Sign-on authorization engine. Please try logging in later, and contact your hosting service provider if the problem persists.


    The port referred to in the KB article is not in the config file. I think it was 11443?
    When I tried to enable the admin like shown in the KB article I get an error, I don't recall the exact text but it didn't like something in the command. I suspect that the disable didn't error out because there was nothing there to disable.

    Any suggestions? I am on a windows OS.

    The KB article says I should see:
    Application type: admin
    Connected with SSO: On
    SSO enabled: Off
    SSO API URL: https://hostname:11443
    SSO Relay port: https://hostname:11444
    Service Provider ID: ubtue6xtmzyafq26xkbmh2i7fdbbcb71lg4b

    I do not. But I do see:
    priviledged_sp_id = ubtue6xtmzyafq26xkbmh2i7fdbbcb71lg4b

    But I don't see ; Super Privileged Service Provider

    Since this is Parallels config file, it is isn't it? I expected to see more text "exactly" as the KB article says but I'm getting seriously nervous that from one version of Panel to the next things drastically change. I've even seen this in the help documentation where paths or files have changed names or locations.
     
Loading...