1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

cgi not working

Discussion in 'Plesk for Linux - 8.x and Older' started by links2world, Apr 29, 2006.

  1. links2world

    links2world Guest

    0
     
    Hello,

    Pleak 8.0.0, I have problems running cgi scripts. I have the following cgi script:

    However, this is not working. In the access_log I havethe following error:

    and in the error_log I have the following:

    Any ideea? Thanks.
     
  2. links2world

    links2world Guest

    0
     
    Okay, selinux seems to be the reason, this is how I fixed it:

    Now CGI is working.

    Regards,
     
  3. OutKa5t

    OutKa5t Guest

    0
     
    Can you explain this fix? I have the same problem as you have decribed but don't understand what your fix is/does.
     
  4. links2world

    links2world Guest

    0
     
    Hi,

    The problem was too resticted SELinux = Security-Enhanced Linux (SELinux) is a version of the Linux kernel and utilities, which contains support for mandatory access controls based on the principle of least privilege.

    For some reason, by default SELinux denies the execution of CGI scripts. audit2allow tool is looking into log files, and if it finds a "deny" log entry, it will display you the "allow" rule that you have to add to your SELinux config files.

    This is what I have done.

    Best regards,
     
  5. DavidCollom

    DavidCollom Guest

    0
     
    Same Error

    I am having the same problem however when i attempt to run your commands above all i get back is this:
    I have tried changing the owner to apache (Read in other topic) and also tried changing the usegroups etc could you give me any more ideas on how to get this to work. the scripts run fine from CLI but not through apache.
    Please help! as i need running for a client who is becoming very impatient.

    David Collom
     
  6. DavidCollom

    DavidCollom Guest

    0
     
    Ok this may sound weird but i moved the CGi files into a subfolder of the CGI bin and now everything works perfectly!, not sure why as all the folders and files have the same permissions and owners!

    Just thought i would make a note of it for others.

    however a fix to run in the root of the bin would be nice!
     
Loading...