1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Change email address for user 'root'

Discussion in 'Plesk for Linux - 8.x and Older' started by cerebrum, May 13, 2008.

  1. cerebrum

    cerebrum Guest

    0
     
    Currently my VPS is configured such that email that is sent to system user root will confuse the mail server and never get anywhere. The qmail logs will show

    qmail: 1210614926.426204 delivery 13085: failure: Sorry._Although_I'm_listed_as_a_best-preference_MX_or_A_for_that_host,/it_isn't_in_my_control/locals_file,_so_I_don't_treat_it_as_local._(#
    5.4.6)/

    Now, I could fix that manually because I know how Qmail works. However, I'm a bit concerned that I might break Plesk that way and therefore would prefer setting an alias (for the domain or the local user root) via Plesk. But how do I do that? I looked everywhere and couldn't find it. :(

    Any hints?
     
  2. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    Plesk writes the Plesk admin e-mail address to /var/qmail/alias/.qmail-root. Changing the address in Plesk will rewrite this alias.

    However, sending mail to root doesn't work, since root is expanded to root@$HOSTNAME and Plesk doesn't set $HOSTNAME in /var/qmail/control/locals (which I believe is a bug), so the message is rejected.
     
Loading...