1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

change mx entry for using different mailserver

Discussion in 'Plesk for Linux - 8.x and Older' started by querbits, Feb 5, 2008.

  1. querbits

    querbits Guest

    0
     
    we tried to change the mx entry at the plesk interface to redirect mails for one domain to a extern mailserver.
    Even with deactivated mailfunction on Plesk Server mails are still delivered to plesk server. nö redirection to the other server.

    We cant change these entries at our provider cause domain is binded to server, no differnt mx entries can be made.

    Is this still possible via plesk or do we have to tranfer the Domain to an other Provider that gives us the possibility to change Domain records?
     
  2. shoggy24

    shoggy24 Regular Pleskian

    25
    57%
    Joined:
    Apr 5, 2007
    Messages:
    198
    Likes Received:
    0
    This is certainly possible on all my plesk server. Did you create an A record for the external mailserver?

    I doubt this is a plesk issue, more likely a DNS or misconfiguration somewhere.
     
  3. plugged

    plugged Guest

    0
     
    Got the same problem here, i've got Plesk 8.2 on my server, added some new a records AND mx records for the mailserver. But the mail is still delivered local, instead of to the external mailserver...
     
  4. elger

    elger Guest

    0
     
    These steps should do the trick if your domain is example.com and the remote mail server is someotherserver.com:

    DNS:
    Make sure you have a dns record like this:
    example.com MX(10) someotherserver.com

    the mx number for the remote server MUST be the lowest number. So this is also allowed:
    example.com MX(10) someotherserver.com
    example.com MX(100) example.com

    LOCAL MAIL:
    local mail always goes before remote mail, so if local mail is deliverable locally, it will be delivered locally.
    No mater what the DNS says.
    The only solution is to disable the mail by using the "Switch Off" button.

    Also remember that it might take a day or more before DNS is updated world wide... You better test by using telnet if you want to know what is happening now:
    search for a site on yahoo or google or some other searchengine: "telnet test smtp" and open a connection to example.com this shoul be accepted and after you submit an email it will be send to someotherserver.com.
    For sure also telnet an email to someotherserver.com
     
  5. plugged

    plugged Guest

    0
     
    How does the local mail know where to deliver the mail?
    Do you also at the mx record in the Plesk DNS?
     
  6. elger

    elger Guest

    0
     
    Qmail (this is the MTA) first looks and sees if it can deliver the mail to a user on the actual server it's self (locally). This is why you must "Swich off" the mail on the "example.com" server. Now if "example.com"would get an email it will no longer diliver it locally.

    Now that Qmail does not accept the mail locally it will turn to DNS and ask DNS what the preferred MX (Mail eXchange) server is. The lower number is the more prefered mail server. If you do the DNS for your domain, then you must fix the DNS settings. If (not very likely) someone else does your DNS, you must not do DNS.
    So in the case you do not do the DNS, turn the DNS for this domain off.
    But if you do the DNS (most likely) you must enter the correct DNS records.
     
Loading...