1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Changing default server ssl cert

Discussion in 'Plesk for Linux - 8.x and Older' started by vesterman, Dec 20, 2005.

  1. vesterman

    vesterman Guest

    0
     
    I bought a webservr ssl cert from Thawte. Succesfully loaded it onto the server, and have it selected as default . However, when I access a page in the https secure area, I still get the "invalid certificate" localdomain.local. How do I get the new Thawte certificate to show up when I log into plesk, and my https pages?
     
  2. eWebtricity

    eWebtricity Guest

    0
     
    Goto IP addresses in the plesk control panel and change the cert assigned to the IP address.

    You can find it under SERVER > IP ADDRESSES

    Remember the cert must match the domain you are assigning it to
     
  3. aviscat

    aviscat Guest

    0
     
    I was told I could set up a cert that could then be used for several domains if I code it correctly. Having never done this I would like some guidance. Thanks.
     
  4. eWebtricity

    eWebtricity Guest

    0
     
    Your talking about a shared or chained certificate. But I don't see how this relates to the original question.
     
  5. vesterman

    vesterman Guest

    0
     
    Goto IP addresses in the plesk control panel and change the cert assigned to the IP a

    Goto IP addresses in the plesk control panel and change the cert assigned to the IP address

    I did that. It still does not work.

    I have purchaed a GoDaddy certificate for my domain evaluebuy.com
    It is activated in plesk under "Clients> ip Pool

    I have purchased a Thawte SSL Server Certificate.
    It is set up for an exclusive ip address I have assigned to my domain evaluebuy.com

    I deleted the plesk default ssl cert that returns invalid cert 'localhost.local domain' bs BUT

    IT STILL SHOWS UP!
     
  6. kyoo

    kyoo Guest

    0
     
    I'm having the same problem.. except I just created a new self-signed cert in plesk 7.5.4.. I can't seem to get my main PSA admin weburl to use the new cert, even though I've set it as the default and set it in the IP setup page, and restarted the psa service (stop, then start).. It keeps showing my old expired self signed cert that I've even removed from the Certificates list inside PSA.

    This must be an issue from upgrading from ancient versions or something.

    Where are the certificates stored on the file system? I can't find my newly created one anywhere. Just my old January 2004 one.

    -Kyoo
     
  7. tylerc

    tylerc Guest

    0
     
    Login to your server

    SERVER -> CERTIFICATES

    Select the certificate you want to use for the control panel and click "SETUP'
     
  8. DeanW

    DeanW Guest

    0
     
    Thanks, that helped me. I couldn't understand how to get my cert to work for the control panel. I tried adding my cert to the domain, to the Server page, removing the default cert, setting ALL ips to use my new cert, all to no avail. This last post here opened my eyes and got me going :cool: - thanks!
     
  9. tylerc

    tylerc Guest

    0
     
    It took me quite a while to figure that out too! I tried many ways from console before I finally figured the easy way.
     
Loading...