1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

chilisoft (SUN ASP 4.x) installation

Discussion in 'Plesk for Linux - 8.x and Older' started by bram, Feb 9, 2005.

  1. bram

    bram Guest

    0
     
    Hello,

    I try to install chilisoft (ASP) / SUN one ASP a fedora core2 with plesk 7.5.2. I follow the installation from the plesk manual (chapter 7).

    Does anyone have succesfull install this?

    kind regards,

    bram
     
  2. Traged1

    Traged1 Guest

    0
     
    The new Sun One Active Server Pages has been released 4.0.2, it solves problems relating to Fedora and RHEL OS'S and the install is very straight forward.
     
  3. Traged1

    Traged1 Guest

    0
     
    The only thing to keep in mind is that you will need to set or tell your clients to set the chmod on their /httpdocs folder to 751 instead of 750 in order to get the asp scripts to execute.
     
  4. bram

    bram Guest

    0
     
    Dear Traged1,

    I install the SUN one administraion console without problems. but can't activate asp for my virtual host.

    The problem is he give there are no virtual host on my web server :

    Server management --> Web server --> Virtual host

    " There is no virtual host on this web server."

    Do you have the same problem? I follow the install manual from the plesk 7.5 manual page 208-209

    my configuration :

    Your server was successfully configured. Its information is as follows: |
    | Server installed (asp-server-3001): |
    | Associated Web server conf file: /etc/httpd/conf/httpd.conf |
    | Associated Web server port: 80 |
    | Location: /opt/casp/asp-server-3001 |
    | Port: 3001 |
    | Samples: Enabled. |
    | Documentation: Enabled. |
    | Automatic ASP start on system boot: Enabled. |
    | ASP started: Yes. |
    | ASP start script: /opt/casp/asp-server-3001/startcaspd |
    | ASP stop script: /opt/casp/asp-server-3001/stopcaspd |
    | ASP restart script: /opt/casp/asp-server-3001/restartcaspd |
    | ASP general control script: /opt/casp/asp-server-3001/caspctrl


    kind regards,

    bram
     
  5. Traged1

    Traged1 Guest

    0
     
    It will not recognize each individual vhost BUT it does give them ALL asp support.

    So if you upload a simple test.asp file to two seperate accounts you can verifiy that it is working.

    Example: test.asp
    --------------------------------------------------------------------
    <html>
    <head>
    <title>ASP Test Page</title>
    </head>
    <body bgcolor="white" text="black">

    <%
    'Dimension variables
    Dim strMessage

    strMessage = "Hello World"

    Response.Write (strMessage)

    Response.Write ("<br>")

    Response.Write ("The time on the server is: " & Time())

    %>

    </body>
    </html>
    --------------------------------------------------------------------

    Remember to chmod the vhost's httpdocs folder to 751, this is how you can control who gets asp support and who does not.

    Those vhosts with thier httpdocs set to 751 will be able to process .asp files and those with the defualt 750 will not be able to and get a 403 error.

    Best Regards..
     
  6. bram

    bram Guest

    0
     
    I try this but keep having the follow error:

    The page cannot be displayed
    The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.

    --------------------------------------------------------------------------------

    Please try the following:

    Click the Refresh button, or try again later....

    The HTTP Error 403 Forbidden in the ASP error log is away with the chmod 751.

    See also this tread at chilisoft.com (http://swforum.sun.com/jive/thread.jspa?threadID=52146)

    thanks,

    bram
     
  7. Traged1

    Traged1 Guest

    0
     
    Ensure that the apache connector directive has been added to your httpd.conf file.

    IE: issue the following from console:

    /etc/init.d/httpd restart

    And watch for the last line of output should look something like:

     
  8. bram

    bram Guest

    0
     
    Traged1 thanks for help.

    I have the same output when I restart apache:

    Stopping httpd: [ OK ]
    Starting httpd: casp2ap: Sun Java System Active Server Pages web server module started, version 4.0.2.35
    [ OK ]
    and this is what i have in httpd.conf :

    LoadModule frontpage_module modules/mod_frontpage.so
    #-------------------------------------------------- Sun Java System Active Server Pages
    LoadModule casp2_module /opt/casp/module/linux2_i686_optimized/apache_2.0.x/20020903/standard/mod_casp2.so
    #-------------------------------------------------- Sun Java System Active Server Pages



    Include /etc/httpd/conf/httpd.include

    ServerName server74.xxxxx.com
    #Include /etc/httpd/conf/mod_jk.conf
    ## Sun Java System Active Server Pages installer
    AddHandler chiliasp .asp
    AddHandler chiliasp .asa
    CaspLib /opt/casp/asp-server-3001

    I don't understand what's wrong. Do you change other things for running SUN asp?

    kind regards,

    bram
     
  9. Traged1

    Traged1 Guest

    0
     
    Also after you edited the vhost.conf file did you issue the command:

    ??
     
  10. Traged1

    Traged1 Guest

    0
     
    What is the output you get for:

     
  11. bram

    bram Guest

    0
     
    Thanks for your help.

    I try this command : /usr/local/psa/admin/sbin/websrvmng -a -v without succes.

    rpm -q perl-Apache-ASP = perl-Apache-ASP-2.57-fc2.build75050128.11
     
  12. Traged1

    Traged1 Guest

    0
     
    Remove it from your server, it will cause problems for Sun One ASP.

    Do a:

    rpm -e perl-Apache-ASP
     
  13. bram

    bram Guest

    0
     
    Ok I have remove apache asp.
    I found in my /etc/httpd/logs/error_log the follow error every time I want to run an .asp page :

    [Wed Apr 27 12:08:49 2005] [notice] child pid 4843 exit signal Segmentation fault (11)
    [Wed Apr 27 12:08:52 2005] [notice] child pid 24103 exit signal Segmentation fault (11)
    [Wed Apr 27 12:08:53 2005] [notice] child pid 26914 exit signal Segmentation fault (11)

    Do someone have the same problem?
     
  14. Traged1

    Traged1 Guest

    0
     
    That is bizzare,

    Did you specify all the right paths during the setup?
     
  15. bram

    bram Guest

    0
     
    Yes,

    I think so. Some SW-soft engineers check the configuration but can't find a solution.

    Dit you install ASP on fedora core or on redhat enterprise 3? I see on the website of sun fedora isn't supported.

    kind regards,

    bram
     
  16. Traged1

    Traged1 Guest

    0
     
  17. huck

    huck Guest

    0
     
    We are currently testing Chilisoft SunOne 4.0.2L. We installed it just fine.


    I removed the Apache ASP component first. The client had this checked in their web site setup, so the Apache:ASP code was in their vhost's httpd.include.

    I had to reconfigure each site to update the httpd.include and then restart apache.

    I chmod the httpdocs 755 and the test script works, so we are now getting ready to move the application over.
     
  18. Traged1

    Traged1 Guest

    0
     
    You might want to use chmod 751 on the httpdocs folder, it is a little more secure, but that is up to you.
     
  19. huck

    huck Guest

    0
     
    We need 755 for another app.....
     
  20. ProfiTiger

    ProfiTiger Guest

    0
     
    The 403-Error is described and fixed in http://swforum.sun.com/jive/thread.jspa?threadID=52321&tstart=75
    It is a problem of the way, plesk handles apache2/httpd.conf.
    Try the second post in this thread, it is the way I could fix the damn 403-error on my server. And httpdocs can stay at 750 ;)
    Greetings,
    ProfiTiger
     
Loading...