1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Control panel access to FTP passive ports

Discussion in 'Plesk for Linux - 8.x and Older' started by cuppett, Oct 8, 2005.

  1. cuppett

    cuppett Guest

    0
     
    Every time I upgrade the base Plesk packages, my proftpd.conf file gets overwritten by a default file.

    Behind a firewall, I have to be selective about the ports I allow, and FTP passive mode ports are just as restrictive.

    I end up adding the following like to /etc/proftpd.conf every time I update Plesk in order to re-establish my passive ports:

    <Global>
    DefaultRoot ~ psacln
    AllowOverwrite on
    PassivePorts 49152 65534
    </Global>

    I would really like it if the control panel gave more access to FTP level parameters, especially the PassivePorts statement. This statement has to go in the global section, so putting it in an include really isn't an option.
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Have you tried putting your customizations in the proftpd.include file instead of the .conf file?
     
  3. cuppett

    cuppett Guest

    0
     
    I thought I had tried that previously, and that parameter needs to be in the Global section and you couldn't have two of those.

    It appears I can back the change out of the global section in proftpd.conf and then create a second Global section with only that parameter in .include

    I do not know if those included in Global in .include are in addition to the already defined, or if it starts over, but it appears to work to control the passive mode ports from there.

    It still would be nice to have access to that type of setting in the control panel though as well as other FTP behaviors.
     
Loading...