1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Courier-IMAP and qmail, sent-mail present but not visible...

Discussion in 'Plesk for Linux - 8.x and Older' started by shrubbery, Nov 16, 2005.

  1. shrubbery

    shrubbery Guest

    0
     
    I'm trying to get sent-mail folders working under Plesk. The sent mail is being saved and kept in:
    Code:
    /usr/local/psa/qmail/mailnames/<domain>/<username>/Maildir/.sent-mail/
    I'm able to read all of the sent mail that is in there, but it is inaccessible through any IMAP client, webmail or otherwise. I've tried it in Horde, Apple Mail, Thunderbird and others, but it just doesn't show up.

    Can anyone help me out?
     
  2. ShadowMan@

    ShadowMan@ Guest

    0
     
    Make sure the ownership and permissions are correct:
    Code:
    drwx------    6 popuser  popuser      4096 Jul  8 06:13 .sent-mail
    
    (then inside the .sent-mail directory)
    -rwx------    1 popuser  popuser        17 May  3  2005 courierimapacl
    drwx------    2 popuser  popuser      4096 May  3  2005 courierimapkeywords
    -rw-r--r--    1 popuser  popuser      1927 Sep 23 04:47 courierimapuiddb
    drwx------    2 popuser  popuser      4096 Sep 23 04:47 cur
    -rwx------    1 popuser  popuser         0 May  3  2005 maildirfolder
    drwx------    2 popuser  popuser      4096 May  3  2005 new
    drwx------    2 popuser  popuser      4096 Sep 28 00:38 tmp
    
    And this is the .sent-mail directory which Horde/IMP created, not one you created manually, right?
     
  3. shrubbery

    shrubbery Guest

    0
     
    Yeah, either Horde (or Courier, or qmail, I don't really know which) created it. My permissions were slightly different (the execute bit wasn't set on the courier acl). I changed them to what you had above, but it didn't make any difference.

    Any other ideas? I know that the sent mail folder is working fine, because its filled with messages that I've sent. Now if I could only see it without having to chunk through them manually, I'd be all set. :)
     
  4. shrubbery

    shrubbery Guest

    0
     
    my fault. it works now that I changed the permissions and restarted Courier-IMAP. Didn't realize I'd have to restart courier.

    So now the question is: Why are these folders getting created with the wrong permissions?
     
  5. AdamCz

    AdamCz New Pleskian

    6
     
    Joined:
    Apr 4, 2014
    Messages:
    1
    Likes Received:
    0
    I miss cPanel so very much.

    did I really just pay 500$ for a crappy cPanel wannabe that can't fix this issue in 8 years? I am experiencing this in Plesk 11.5 in the year 2014. Awesome.

     
Loading...