1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

CPAN question / How To...

Discussion in 'Plesk for Linux - 8.x and Older' started by nhouse, Jul 6, 2005.

  1. nhouse

    nhouse Guest

    0
     
    Hello Everyone... I know this may not be "directly" related to Plesk but please give me some tips if you don't mind. I have a Virtual Dedicated Server using RedHat 9 and Plesk 7.5.3 and I do have root access.

    Ok, I am not the sharpest knife in the drawer on command line stuff... so please keep that in mind. If you have the time to reply to this, please type out the commands exactly as they should be used. I am a special needs Linux newbie :D

    Ok, here we go... I use several PHP script sets that need certain Perl modules installed. I have a "general" knowledge of installing modules with CPAN. However, when I log in as ROOT using Putty and SSH, nothing happens when I try to start the CPAN shell. I have tried typing in CPAN as well as perl -MCPAN -e shell and I get a message saying Can't locate CPAN.pm in @INC (@INC contains: /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 .).

    So, I started wondering if my virtual server actually had CPAN on it? I'm not sure if that is a item that is a default in their (GoDaddy's) installation. SO... I tryed typing in locate CPAN.pm and go this message warning: locate: could not open database: /var/lib/slocate/slocate.db: No such file or directory
    warning: You need to run the 'updatedb' command (as root) to create the database.


    Before I do anything else... advice please. I sure don't want to screw the whole thing up, if ya know what I mean!
     
  2. serve-you.net

    serve-you.net Guest

    0
     
    Go ahead and run 'locate -u', that will give you the updatedb. CPAN should be part of your default perl install, but maybe your provider uses a trimmed down version on the VPS.
     
  3. nhouse

    nhouse Guest

    0
     
    I held my breath and did the update as the terminal instructed. and tried to locate CPAN.pm and it wasn't to be found. Sooooooooooo, I really got brave and installed CPAN myself (first time to do a manual perl module install) and then I REALLY got brave and installed ImageMagick. It wouldn't install through the CPAN shell... rats! Whew... lot's of "firsts" for me the last few days.
     
Loading...