1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Create New Domain Error: Invalid Pointer

Discussion in 'Plesk for Windows - 8.x and Older' started by Tikkune, Mar 9, 2007.

  1. Tikkune

    Tikkune Guest

    0
     
    I cannot create a new domain since an upgrade from Plesk 7.6 to Plesk 8.1 revision. This is the error I get whenever I attempt to create a new domain:

    Failed domain creation: Unable to update domain data: Unable to create dumps directory: Execute websrvmng --add-domain "--domain-name=test.com" failed: Invalid pointer (COM Error 80004003) at addSiteLink(sitebuilder, sitebuilder, test.com)
    ---------------------- Debug Info -------------------------------
    0: C:\Program Files\SWsoft\Plesk\admin\htdocs\domains\create_domain.php:146

    :confused:

    Any ideas what might be wrong?

    I had uninstalled Sitebuilder 2.1 using steps provided by SWsoft. Now I feel this may be the problem (since the error references sitebuilder).

    Also, from Event Viewer:

    Event Type: Error
    Event Source: Plesk: websrvmng.exe
    Event Category: None
    Event ID: 1
    Date: 3/9/2007
    Time: 10:35:48 AM
    User: N/A
    Computer: FC
    Description:
    Invalid pointer (COM Error 80004003) at addLinkSite(sitebuilder, C:\inetpub\vhosts\sitebuilder)
    at (WebServerAdapter::addLinkSite line 4071)
    at install(WebServerAdapter::install line 65)
    at execute console command --add-domain(vconsoleapp::start line 128)
    at execute "C:\Program Files\SWsoft\Plesk\admin\bin\websrvmng" --add-domain "--domain-name=test.com"(vconsoleapp::run line 138)
    Execute file name: C:\Program Files\SWsoft\Plesk\admin\bin\websrvmng.exe

    (and second entry in Event Viewer)

    Execute websrvmng --add-domain "--domain-name=test.com" failed: Invalid pointer (COM Error 80004003) at addLinkSite(sitebuilder, C:\inetpub\vhosts\sitebuilder)
    at (execUtil line 107)
    at Execute C:\Program Files\SWsoft\Plesk\admin\bin\websrvmng --add-domain "--domain-name=test.com"(execUtil line 111)
    at Create domain test.com(domainmng::addDomain line 41)
    at execute console command --add-domain(vconsoleapp::start line 128)
    at execute "C:\Program Files\SWsoft\Plesk\admin\bin\domainmng.exe" --add-domain "--domain-name=test.com"(vconsoleapp::run line 138)
    Execute file name: C:\Program Files\SWsoft\Plesk\admin\bin\domainmng.exe
     
  2. Tikkune

    Tikkune Guest

    0
     
    I paid for SWsoft support to fix this issue; here is what they did to resolve the problem:

    ---

    I fixed the issue. I used regedit and deleted the site cache: HKEY_LOCAL_MACHINE\SOFTWARE\PLESK\PSA Config\Config\SitesCache

    Next time you create a domain or run websrvmng command, sites cache will be created automatically.

    After, I was able to create a domain successfully (swtestsw.com). Please check the domain.

    Thanks,

    Yulia Minenkova
    Technical Support Engineer
    SWsoft, Inc.
     
  3. fornex

    fornex Guest

    0
     
    Thanks! This solved my problem!
     
  4. Tikkune

    Tikkune Guest

    0
     
    I am SO happy when someone else can benefit from my experience. It makes paying for SWsoft support... much less painful. ;)

    So far as I know, SWsoft does NOT follow-up paid support incidents by posting solutions for one client for others to benefit. I wish they did. It's up to us to keep suggesting that SWsoft improves their process for adding Knowledgebase How-To-Fix entries, and until they do, we can show them how to do it.

    For anyone who fails to enter a solution just because their problem is fixed, please reconsider sharing your knowledge and making it easier on the next person. It takes time to do so, yes - but as you can see here, it's worth it. Next time you need an answer it might already be here and you can save time and $75.
     
  5. realani

    realani Guest

    0
     
    I had a very similar problem. It seems to be related to a defect in the PLESK software. You would think that they should cover the cost of fixing problems directly related to obvious bugs in their software until a patch or minor version is released with a fix. *hint hint SWSOFT*
     
  6. pmoura

    pmoura Guest

    0
     
    Thanks Tikkune, it worked for me. You save my day. I've running this issue for 2 weeks...
     
  7. vizteck

    vizteck Guest

    0
     
    Thanks a lot

    Hi

    Thanks a lot.. you save me a lot of time

    Barkan
     
  8. Tikkune

    Tikkune Guest

    0
     
    Welcome

    My favorite email notification messages are the ones that come in from instructional posts I made, where people, like you, have replied by saying 'thanks'. So, thank you, too.

    :)
     
  9. alta

    alta Regular Pleskian

    26
     
    Joined:
    Sep 27, 2007
    Messages:
    118
    Likes Received:
    0
    actually, it would be do nothing in registry you can do do it in command line as well:
    C:\Program Files\SWsoft\Plesk\admin\bin>websrvmng.exe --remove-sites-cache
     
  10. informatica_be

    informatica_be Guest

    0
     
    I had this when generating statistics.
    Your solution helped me also.

    Thank you very much.
     
Loading...