• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Database Error after Upgrade to PHP5.2

T

teddy

Guest
Hi,

i upgrade today my php 5.1.6 tp php 5.2.13
php and all user mysql-database works correctly, but i have not access as root (over the plesk panel) to mysql.
i can´t create new databases or change databases (e.g. password or user)
also i can´t change the admin-password.

error-message on plesk - when i will create a db-user:
Table 'mysql.servers' doesn't exist

all permission from plesk to the database not avaible.

what can i do?
 
Mysql root user is replaced to admin user during Plesk installation. You can use following command for full access to mysql:

mysql -uadmin -p`cat /etc/psa/.psa.shadow`
 
Fixed

Hi,

the Problem was fixed.
The error was not a problem from plesk - but i´ve installed the php5 update from http://www.atomicorp.com/
In this update i alos installed a mysql upgrade.
On this it gives an error - but one database table are not present an mysql was looking for them.

I create the table with server in the database mysql with:

CREATE TABLE `servers` (
`Server_name` char(64) NOT NULL,
`Host` char(64) NOT NULL,
`Db` char(64) NOT NULL,
`Username` char(64) NOT NULL,
`Password` char(64) NOT NULL,
`Port` int(4) DEFAULT NULL,
`Socket` char(64) DEFAULT NULL,
`Wrapper` char(64) NOT NULL,
`Owner` char(64) NOT NULL,
PRIMARY KEY (`Server_name`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8
COMMENT='MySQL Foreign Servers table';
 
Back
Top