1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Database issues after upgrading to 10.4.4

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by SethRegan, Jan 11, 2012.

  1. SethRegan

    SethRegan Guest

    0
     
    Hello All,

    I would really appreciate any help you could provide with this issue, have been banging my head against a wall for 3 days now trying to resolve it myself.

    I am running a Windows 2003 64bit box originally using Plesk 9.x, which apart from being a bit slow worked! I am a big believer in keeping all software and patches up-to-date, so I backed up everything and use the upgrade feature within the Plesk panel to upgrade from 9.x to the newest release version 10.4.4.

    The actual upgrade itself went ok, or so it looked, initially I had noticed it had broken the email system, which I have managed to resolve myself after a bit of Googling and needed to get my host to sort out another issue to do with remote management settings.

    It wasn't until I come to upgrade a couple of components, mainly the web mail's where I have found another issue, which is really doing my head in.

    The upgrade fails with the following notice:

    <---------------------------------------->
    Installation started in background
    Determining the packages that need to be installed.
    File downloading PANEL-WIN_10.4.4/dist-msi-Microsoft-2003-i386/atmail.msi:completed.
    Starting installation of packages
    upgrading Atmail...
    MSI: Error! Critical action 'Creating Atmail database...' has been failed:
    Command "C:\Parallels\Plesk\admin\bin\local_mysql_helper.exe" --create-database-and-user -database "atmail" -database-user "atmail" -database-user-password "MFk4cZ9z0kK8" failed with code 3.
    Output:
    Create new database failed: Failed to connect to database: Access denied for user 'admin'@'127.0.0.1' (using password: YES)

    Failed to install 'C:\fb4993fa4d0886d43aa55da25a4acfd9\parallels\PANEL-WIN_10.4.4\dist-msi-Microsoft-2003-i386\atmail.msi': Fatal error during installation. (Error code 1603)
    Error: Action sequence 'upgrade: upgrading Atmail...' of package 'atmail' has been failed with code 1603
    Not all packages were installed.
    Please, contact product technical support.
    <---------------------------------------->


    It is quite clear what the problem is, obviously a mismatch of stored passwords somewhere, this is not only preventing me from upgrading any components which require mysql access but also I am now unable to create new databases for any domains that are hosted. I can't even update the password using the Database servers section in the Plesk Panel, this also means I can not use the phpmyadmin link in the control panel.

    I have spent 3 days Googling and trawling through forums trying to find a solution, I find plenty about fixes similar issues under Linux but nothing for Windows.

    Has anyone else had this problem and been able to resolve it or can anyone give me any guidance in how to fix this issue.

    This is not the first time upgrading the Plesk panel has broken something, really should test the updates more thoroughly before releasing them, this should not happen, never happens to any of my updates I release for the software I develop!

    Any help would be greatly received!

    Thank you in advance.

    Seth
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Looks like you have different admin's passwords in Plesk and MySQL server. Try to change password using the following Plesk utility:

     
  3. SethRegan

    SethRegan Guest

    0
     
    Thank you for the quick reply, unfortunately I have already tried that and am still having the same issue, any other suggestions at all?

    Thanks in advance!

    Seth
     
  4. SethRegan

    SethRegan Guest

    0
     
    Another update,

    I have logged in to the Plesk Administration Panel using the admin username and password successfully so have confirmed the Panel is responding to the correct password.

    Secondly I have been able to login to the Plesk MySQL database using the username admin and the same password as was used when logging in to the Control Panel.

    So far I have confirmed the admin password for the Plesk Panel and the Plesk MySQL Database match and are working fine.

    The issue is with the client MySQL database on port 3306.

    I can see the user admin but the password is not accepted, I have manually set the password for the admin account on the client database to match the the Panel and Plesk DB one and still rejects my credentials.

    I can see in the user table that once I changed the admin account password, the stored hash does change, I confirmed the hash password was correct as I created a temporary account using the same passwords, which then matches the admin's hash and I can log in to this account using the admin password.

    But still the client MySQL is refusing to accept any connection to the admin account on the local or a remote machine, this does not make sense at all, something seems really wrong with the database as the same password used on a temp account works fine but is still rejected for the admin account.

    Hope someone can get this working, at this moment in time I am completely unable to update or upgrade Plesk and I am not able to create any new domains or create a new database under a domain.

    Thanks you in advance.

    Seth
     
  5. SethRegan

    SethRegan Guest

    0
     
    Anyone able to shed some light on this issue, I am still unable to manage the client MySQL database through Plesk Panel.

    Thank you in advance.

    Seth
     
  6. InderS

    InderS Silver Pleskian

    15
    30%
    Joined:
    Apr 17, 2013
    Messages:
    968
    Likes Received:
    1
    Location:
    Nashik
Loading...