1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Defaulting to DNN directory

Discussion in 'Plesk for Windows - 8.x and Older' started by badkneecap, Mar 30, 2006.

  1. badkneecap

    badkneecap Guest

    0
     
    I installed DNN in a subdirectory, as the installation requires. How can I change the site setup in Plesk so that when someone goes to the default domain, it actually is in the installed dnn directory without the user seeing it?

    So, if the user goes to http://mywebsite.com, in reality it's in the http://mywebsite.com/dnn directory?

    This seems like it should be a simple fix, otherwise what's the point in being able to install those ASP.NET applications?

    - PR
     
  2. OlegB

    OlegB Guest

    0
     
    Unfortunately Plesk can't adjust this feature yet. But I can offer you to use some kind of workaround. You need just create index.html file contained the following text:

    <HTML>
    <HEAD>
    <TITLE></TITLE>
    <META http-equiv="Content-Type" content="text/html; charset=UTF-8">
    <META http-equiv="Cache-Control" content="no-cache">
    </HEAD>
    <FRAMESET rows="*,0">
    <FRAME src="http://mywebsite.com/dnn" noresize>
    <NOFRAMES>
    Your browser does not support frames.
    </NOFRAMES>
    </FRAMESET>
    </HTML>

    This file will forward http://mywebsite.com to http://mywebsite.com/dnn
     
  3. badkneecap

    badkneecap Guest

    0
     
    I tried your suggestion but it didn't work.
     
  4. Skeeter

    Skeeter Guest

    0
     
    Hi, badkneecap

    Have you put this file in the

    vhosts\mydomain.com\httpdocs\

    folder? You also need to make sure, that the index.html is in the documents settings for this domain.

    Does this help?
     
  5. badkneecap

    badkneecap Guest

    0
     
    Yes, I saved the above code as index.html in the \httpdocs directory. It loads, because I can see the above code when I view the source code. However, nothing shows up, not even the no frames message.
     
  6. Skeeter

    Skeeter Guest

    0
     
    Hi, badkneecap

    Make sure, that your DNS configuration is fine on your server.
    Try to browse this site from your server.

    Is this useful?
     
  7. Skeeter

    Skeeter Guest

    0
     
    Hi, badkneecap

    I`m sorry, what I told you in the last post was something useless %).
    Ok, you need to check, if you can browse the URL from your client. Also, in your browser you can go to "view source" and make sure that the html page has been loaded correctly.
     
  8. badkneecap

    badkneecap Guest

    0
     
    Yes, I checked both of those and they're working. Weird.
     
  9. Ryan11433

    Ryan11433 Regular Pleskian

    25
    57%
    Joined:
    Jun 27, 2005
    Messages:
    184
    Likes Received:
    0
    use meta redirect
     
  10. badkneecap

    badkneecap Guest

    0
     
    Can you explain?
     
  11. Ryan11433

    Ryan11433 Regular Pleskian

    25
    57%
    Joined:
    Jun 27, 2005
    Messages:
    184
    Likes Received:
    0
    look it up on google
     
  12. Skeeter

    Skeeter Guest

    0
     
    Hi, badkneecap

    Could you please provide me with this link? Maybe this is a browser-related issue?
     
  13. badkneecap

    badkneecap Guest

    0
     
    A meta redirect is not the solution I was looking for. If that was the case, I could have simple used an ASP redirect to the /dnn directory. The issues I'm trying to resolve is to change it so the user doesn't see the /dnn directory name as the end.

    I solved this problem by creating the new site locally and pushing it up to the server in the root directory. That solves my problem, but I would think that this problem still exists for many people out there. When I first started messing around with DNN, for $10 a month, I opened an account where I could install it for my account. But it required that I install it in a subdirectory. Personally, if I had to redirect my users to the /dnn directory on my site so users can my website, I wouldn't like it. It would look very unprofessional to me if I saw this on someone else's site.

    Thanks for the suggestions.
     
Loading...