1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

disabling www prefix for domain

Discussion in 'Plesk for Linux - 8.x and Older' started by arjenjb, Jul 27, 2005.

  1. arjenjb

    arjenjb Guest

    0
     
    Running Plesk 7.5, I wanted to have a www-subdomain, so that mydomain.com and www.mydomain.com have a different htdoc root.

    1. I unchecked the www-prefix checkbox for my domain. When i checked my httpd.include i noticed that 'ServerAlias www.mydomain.com' was gone, that's ok.

    2. I created a new subdomain 'www'.

    Now when I try to access www.mydomain.com I get the index page of 'mydomain.com'. Not right, I'm supposed to see the index page of 'WWW.mydomain.com'.

    When I checked the httpd.include file 'ServerAlias www.mydomain.com' in the virtualhost settings for 'mydomain.com' was there again??

    And I check the www-prefix checkbox for mydomain.com, and it was still unchecked, it was even grayed, probaly because there's a www-subdomain.

    But i doens't work! Anyone familiar with this problem? Any solutions?

    Best regards,
    Arjen
     
  2. hardweb

    hardweb Guest

    0
     
    You can not have www as subdomain, this is a Plesk design issue. There are couple of solutions, but not from interface (or you can use 4PSA Total Domains for this, which is different on subdomain handling).
     
Loading...