1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

DNS using external nameserver

Discussion in 'Plesk for Linux - 8.x and Older' started by areiseek, Dec 21, 2005.

  1. areiseek

    areiseek Guest

    0
     
    I'm having trouble getting a domain to resolve using an external nameserver. (using 7.5.2 RH9)

    I have about 25 domains working properly using my own nameserver with zone records based on posts in this forum.

    Now I have a client who wants to use an outside nameserver and maintain their own records... No problem... per the manual and info from the forum, just disabled DNS on this one domain. I decided to test with a spare domain before I have my customer make any changes and I keep having a problem with the "www" address! It's been at least 3 days since I last made any changes to my zone files using zoneedit.com. If I try "testdomain.com" everthing works great... I get the testdomain default page in Plesk. But if I try "www.testdomain.com", I get the default page for MY server. I'm using a shared IP for all domains. Here's the zone record I'm using:

    testdomain.com. A 111.222.333.444 (shared IP)
    mail.testdomain.com. A 111.222.333.444
    webmail.testdomain.com. A 111.222.333.444
    testdomain.com. MX 10 mail.testdomain.com.
    ftp.testdomain.com. CNAME testdomain.com.
    www.testdomain.com. CNAME testdomain.com.
    testdomain.com. NS ns2.zoneedit.com.
    testdomain.com. NS ns17.zoneedit.com.
    testdomain.com. TXT "v=spf1 a mx ~all"

    I'm a newbie... any help is appreciated. Thanks, Rick
     
  2. tmonsen

    tmonsen Guest

    0
     
    I've seen several posts lately that say restarting psa resolves similar issues. You may want to give that a try, as your zone record looks correct.
     
  3. areiseek

    areiseek Guest

    0
     
    I tried a restart... still not working.

    A side question, To restart psa, I used the gui at Server>Services management and stopped and started all the services (Apache & BIND first). Was that the correct way to restart? That didn't fix the problem so late last night I rebooted the server just to make sure. Still not working this morning.

    Thanks, Rick
     
  4. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Try changing hte www to an A record instead of a CNAME.

    Also, you have to restart psa from the command line, not the gui. That restarts other services, not psa.
     
  5. areiseek

    areiseek Guest

    0
     
    I changed the www to an A record on the 23rd:
    www.testdomain.com. A 111.222.333.444
    -still not working

    just restarted PSA with this command: service psa restart
    If that's correct, still not working.

    I have disabled DNS, but per the manual, Plesk will make the nameserver a clickable link to validate the zone configuration... I get the following message, does it provide any clues?:

    Name: testdomain.com Address: 111.222.333.444 testdomain.com nameserver = ns17.zoneedit.com. testdomain.com nameserver = ns2.zoneedit.com. testdomain.com mail exchanger = 0 mail.testdomain.com. Name: www.testdomain.com Address: 111.222.333.444 *** Ok : Domain A record is valid. *** : Must be - 111.222.333.444, now - 111.222.333.444 *** Warning: MX record does not resolve for your domain - *** Ok : Domain A www. record is valid. *** : Should be - 111.222.333.444, currently resolves to - 111.222.333.444

    Thanks, Rick
     
  6. areiseek

    areiseek Guest

    0
     
    I fixed it.

    I removed and then re-created the domain. It started working immediately. Maybe I did something wrong the first time I created the domain??

    Thanks for the suggestions, Rick
     
Loading...