1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Domain not getting files from correct directory

Discussion in 'Plesk for Linux - 8.x and Older' started by Megamec, Oct 21, 2005.

  1. Megamec

    Megamec Guest

    0
     
    3 days ago, I signed for a root server III with 1and1. I was able to configure my first domain name on it (with 1and1 control panel) and created my domain under Plesk (never use it before). For some reason, each time I requested my domain name on my browser (www.mysite.com), I still have the default 1and1 contruction page instead of my proper index.html file. After a few test (thank's again Andrew), we were able to find that :

    Each time I requested my domain name on a browser, for some reason, the files are taken from this directory : /home/httpd/vhosts/default/htdocs/
    instead of this folder : /home/httpd/vhosts/mysite.com/httpdocs/

    Do you have any idea Why?

    The server should be ready to use when you have it without any problem
     
  2. revolution

    revolution Guest

    0
     
    possibly you are experiencing a problem where apache does not get restarted automatically after the set restart interval after you add/edit a domain. try running the following command as root and see if the site then works as you expect:

    apachectl graceful

    note that i had this problem (apache not being restarted) with plesk 7.5.2 on a fc2 server at 1and1 and i ended up cron'ing the apachectl graceful to happen hourly to get around it. there are also other people here in the forums with this same problem but i have not seen a solution. it may be working on that server, actually, after the upgrade to 7.5.3 but i can't really remember and i don't feel like testing it right now.

    http://forum.plesk.com/showthread.php?s=&threadid=22128


    i think it may be isolated to fc2 as i haven't had this problem on any redhat servers, redhat 9 or rhel3 (this server that had the problem is the only fedora server i deal with).
     
  3. Megamec

    Megamec Guest

    0
     
    I found the problem this morning...begginer one :rolleyes:

    I used the wrong transfert type on my files (Auto). I just switched to Binary and the problem was solved.

    For some reason, if the type of my file index.html was transfert on Auto mode, the server link automaticaly to /home/httpd/vhosts/default/htdocs/index.html
     
  4. revolution

    revolution Guest

    0
     
    hi,

    i highly doubt the ftp transfer mode makes any difference to apache when it is trying to server a file. how would apache know what type of line endings are supposed to be in that file? and i've never heard of apache kicking over to another directory of the default domain because it didn't like the file it was asked to server (unless the ErrorDoc it was configured to server was from a different directory, regardless of the domain).

    i'm glad it's working for you for now, but i just don't think you'll find this is the actual problem when you add your next domain. i think most likely this is coincidence that it started working after you tried changing the ftp transfer mode. you should try to repeat this with a new domain. if you find it repeatable (on multiple occasions, and waiting different periods of time, from hours to days, before changing the ftp transfer mode you use to test this theory), then i'm wrong about the ftp transfer mode the problem in your case.
     
  5. Megamec

    Megamec Guest

    0
     
    I did a test just for fun. On my good directory, I rename my index.html and automaticaly, it goes to /home/httpd/vhosts/default/htdocs/index.html. that proove that each time you requested a file index.html and it's not there or it as the wrong type (ASII), it transfert to the wrong directory.
     
Loading...