1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Downgraded Mysql and now plesk won't run

Discussion in 'Plesk for Linux - 8.x and Older' started by adamluz, Jul 18, 2007.

  1. adamluz

    adamluz Guest

    0
     
    I needed to down grade my mysql and now plesk won't run. how can I fix this? Error message is below:

    ERROR: PleskMainDBException
    MySQL query failed: Table './psa/misc' was created with a different version of MySQL and cannot be read

    0: /usr/local/psa/admin/plib/common_func.php3:216
    db_query(string 'select param, val from misc')
    1: /usr/local/psa/admin/plib/common_func.php3:513
    get_param(string 'mysql41_compatible')
    2: /usr/local/psa/admin/plib/common_func.php3:410
    db_set_names()
    3: /usr/local/psa/admin/plib/common_func.php3:389
    db_connect_real(string 'localhost', string 'admin', string '********', string 'psa')
    4: /usr/local/psa/admin/plib/common_func.php3:369
    db_connect()
    5: /usr/local/psa/admin/auto_prepend/auth.php3:87
     
  2. adamluz

    adamluz Guest

    0
     
    Re-upgraded the mysql to just get past these issues. Now psa won't start. Attempted to reinstall and this is what happens


    ===> Installing rbash
    Checking that /bin/rbash registered as login shell...
    /bin/rbash is already registered as login shell

    ===> Installing psa database
    Trying to define valid mysql credentials... Trying to establish test connection... connected
    done
    Trying to remove chunks from MySQL database... done
    done
    Trying to establish test connection... connected
    done
    Trying to check psa database... Trying to find psa database... DATABASE ERROR!!!
    Database psa found, but version undefined

    ERROR while trying to find psa database
    Check the error reason(see log file: /tmp/psa_8.2.0_fc4.build82070706.15_upgrade.070718.10.13.log), fix and try again

    Aborting...

    error: %post(psa-8.2.0-fc4.build82070706.15.x86_64) scriptlet failed, exit status 1
    12:psa-awstats-configurato########################################### [ 75%]
    13:psa-horde ########################################### [ 81%]
    Trying to establish test connection... connected
    done
    14:psa-api ########################################### [ 88%]
    15:psa-imp ########################################### [ 94%]
    Trying to establish test connection... connected
    done

    ERROR while trying to execute SQL query, the query was: REPLACE Components (name, version) VALUES ('psa-imp', '4.1.4')
    Check the error reason(see log file: /tmp/psa-imp_4.1.4_fc4.build82070706.15_upgrade.070718.10.13.log), fix and try again

    Aborting...

    error: %post(psa-imp-4.1.4-fc4.build82070706.15.noarch) scriptlet failed, exit status 1
    16:psa-updates ########################################### [100%]
     
  3. adamluz

    adamluz Guest

    0
     
    got psa running again... sheesh, but i still need to downgrade mysql. Is this possible on 8.2? with out having conflicts?
     
  4. adamluz

    adamluz Guest

    0
     
    nevermind, re-wrote php scripts - thanks anyway
     
  5. jacko@

    jacko@ Guest

    0
     
    Would have been nice to know if there was a solution (other than re-writing the PHP scripts) to this. I'm in the same position and hoping not to have to re-install Plesk.

    Jacko
     
Loading...