• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Duplicate mail headers with multiple receipients

Flachzange

Basic Pleskian
A customer reported a bug where mails were rejected due to multiple x-headers:


For example:

host mx-rz6.energie-rath.de[88.198.232.66] said: 554 5.7.7 too many equal X-headers (X-No-Relay:) (in reply to end of DATA command)


The cause are indeed too many x-headers of type x-no-relay in the mail. I could reproduce it by simply adding more multiple recipients to the mail. For every recipient, a separate header tag is generated.

Thx for helping!


---------------------------------------------------------------
PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE

PLESK, 10.4.4#27, Ubuntu 8.04, x86

PROBLEM DESCRIPTION

Postfix generates a x-no-relay header for every recipient in the mail causing other mail servers rejecting this mail.

STEPS TO REPRODUCE

Write an email to two or more recipients.

ACTUAL RESULT
At least two x-no-relay entries.

EXPECTED RESULT
One x-no-relay entry

ANY ADDITIONAL INFORMATION
--------------------------------------------------------------
 
I have forwarded your report to developers. I will update thread with results when I receive them.
 
As workaround just remove non_auth.re and no_rely.re records in main.cf for Plesk >=10.4
or clean:
/var/spool/postfix/plesk/non_auth.re
/var/spool/postfix/plesk/no_relay.re
 
It will be completely fixed in upcoming Plesk 12.
 
Back
Top