1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Email, 1and1, User unknown

Discussion in 'Plesk for Linux - 8.x and Older' started by dugjohnson, Apr 20, 2006.

  1. dugjohnson

    dugjohnson Guest

    0
     
    I have a 1and1 root server. Setting things up has gone pretty fair so far. My past experience is BSD and Sendmail, this is Fedora 2 and Courier/Qmail.
    Checking the boards here first, I have tried several different ways of sending mail through.
    1and1(s) default, which is supposed to send through to my server, then to 1and1, and also setting up a mail.mydomain.com.com record in 1and1s Control panel and having mydlomain.com mx record point to it.
    The users are set up in Plesk on the server.
    For instance, with ohmygodno.com
    The message I get when sending an email to a user on the new server is
    Mail server responded 5.1.1 <newtest@ohmygodno.com> user unknown.
    I am thinking it is a DNS issue, but I haven't been able to track it down any further. I am willing to point to the Plesk server as the name server, but only have one server, not two. I would prefer a solution that allows me to continue to use 1and1.com name servers, only because my knowledge of DNS is sketchy at the moment....I've done some work with it, but not tons.
    pinging mail.ohmygodno.com does return the correct IP of the server.
    Looking for direction, diagnostics that I can run...basically a solution. Once the email is working I can migrate my clients and close down the old server at another provider. Until then, no emergencies, but I'd like to get it done.
    TIA.
    Doug
     
  2. Highland

    Highland Guest

    0
     
    You shouldn't need to do anything in the 1and1 panel beyond point the domain to your server. Plesk handles your DNS from there. I'd delete mail.mydomain.com from your 1and1 panel and see if the problem goes away.
     
  3. dugjohnson

    dugjohnson Guest

    0
     
    Thanks....I had actually tried that, and done it several different ways, but the confirmation that it ought to work the normal way helps. I have reset everything, will let it propogate through its own servers and will stop and then restart all services and see where I am. It seemed to me that it ought to work also. I had a failed re-image last weekend (apparently some problem with Fedora 4 and Plesk 8 that 1and1 has) so I was feeling a bit edgy. If it works, I'll post. If it doesn't, I will ask for more info. Back in a coupla hours.
     
  4. dugjohnson

    dugjohnson Guest

    0
     
    Got IT!

    Turns out it wasn't 1and1 or Plesk at all. I am in the early stages of moving things over systematically, testing before moving (sounds intelligent, right?). Although I had pointed the DNS to the new nameserver, the old record in the old ISP nameserver was still pointing to the old address.
    I was using my current SMTP (on the old server). It was checking the test names against the old server, where they didn't exist, and sending to the old server, even though the real world DNS was set up correctly.
    Changing the outgoing mail to be the new server, all went as it should have in the first place. I am now going to have someone else send me test mail to be sure all is well, but things look good to go.
    I am posting this in case someone else has a similar problem.
     
  5. wagnerch

    wagnerch Guest

    0
     
    Best thing to do is to tweak the TTL on the SOA, A, CNAME, etc records a day or two before you plan on moving. I normally bump the TTL down to 10 minutes, change the A records on my old ISP and bump the TTLs back up. Then I will go into my registrar and change the name servers, doing it this way it is fairly transparent. It means you have to hang on to the old ISP for a few days after the DNS changes, but it is worth it.
     
Loading...