1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Enable Smarter Mail

Discussion in 'Plesk 10.x for Windows Issues, Fixes, How-To' started by GregZ1, Dec 6, 2010.

  1. GregZ1

    GregZ1 Guest

    0
     
    I have Smarter Mail 7.3.3952 installed on my webserver and Parallels 10 recognizes it. When I select it in Server and Panel settings and click OK, it sits there for a while and then reloads the page. I have checked that the password and port are correct. Is there something I am missing?
     
  2. GregZ1

    GregZ1 Guest

    0
     
    Solved

    I solved the issue by removing all users and domains that I had setup in Plesk control panel.
     
  3. AndorA

    AndorA Basic Pleskian

    21
    57%
    Joined:
    Nov 30, 2009
    Messages:
    58
    Likes Received:
    0
    How to upgrade Plesk 9 -> 10 when you run SmarterMail

    I also had some trouble with SmarterMail when upgrading from Plesk 9.5 to 10. The problem is that an installed Plesk recognizes SmarterMail, but the installer does not. Therefore it forces an install of MailEnable on you, which impedes the proper functioning of SmarterMail.

    Here is how I solved it:

    - Before installing the upgrade of Plesk 10, backup SmarterMail. It's very simple, you find a guide here: http://portal.smartertools.com/KB/a1067/backup-and-restore-smartermail.aspx
    - Remove all settings and accounts from SmarterMail (I choose to deinstall and upgrade to a new minor version while I was at it; the point is to get a clean SmarterMail installation)
    - Once you have a clean and empty SmarterMail installation, install Plesk and let it install MailEnable. If you are on a live server, make sure you disable the MailEnable services in Windows Services as soon as it's installed, otherwise mails received by MailEnable will not reach your clients in SmarterMail.
    - When Plesk is running, go to System Components and switch your mail server to SmarterMail. Depending on how many domains and mailboxes are set up through Plesk, this might take a while. Plesk will recreate all accounts in Smartermail. In the next step you delete all those, but it's necessary to make Plesk know the accounts are there.
    - When Plesk is ready, simply restore the backup of all your SmarterMail settings, accounts and mailboxes (again, see the easy guide of SmarterTools on http://portal.smartertools.com/KB/a1067/backup-and-restore-smartermail.aspx).
    - Now you can simply deinstall MailEnable directly from Windows Programs and Features in the Control Panel; it is one of the few Plesk components that actually shows up there.

    And voilá, Plesk 10 running SmarterMail!
     
    Last edited: Dec 18, 2010
  4. Brian at Ironstone

    Brian at Ironstone New Pleskian

    15
    80%
    Joined:
    Jan 23, 2011
    Messages:
    5
    Likes Received:
    0
    Before I start these steps...

    Thanks for the post. I have a clean Plesk10 that was working with Horde Mail. I needed to switch to SmarterMail and choose SmarterMail Pro 7. That's where the problems started, but I now have SmarterMail installed, running in a separate App Pool in IIS and working. See: http://kb.odin.com/1171

    This however does not fix the issue and SmarterMail remain not configured

    Plesk sees Smarter Mail and I can select Smarter Mail as the Mail Server, but it keeps reverting to not configured. Whenever I set the "Parameters of SmarterMail Server 7.4.3995" (in Home>Server and Panel Settings>Server Components)
    I get the error:


    I can restart the SmartMail Mail Server and get SmarterMail configured, but whenever I setup in IIS I get this issue.

    Any ideas would be greatly appreciated.
     
  5. AndorA

    AndorA Basic Pleskian

    21
    57%
    Joined:
    Nov 30, 2009
    Messages:
    58
    Likes Received:
    0
    Well, ideas is all I can give you. But let's see:

    - Which version of Plesk are you running? If it's less than 10, it might not work with SmarterMail 7.4. You might want to downgrade to a lower version (or upgrade to Plesk 10)
    - Maybe the SmarterMail-server is still running, even though you set up an IIS site.
    - If you are running SmarterMail on a non-default port number (i.e. different from 9998), you might want to try switching to the default port to see if that makes a difference.
    - Of course you already tried, but reboot the whole server once (i.e. Plesk and SmarterMail), doublechecking that the SmarterMail build-in server is switched off.

    That's about all I can think of. Good luck!
     
  6. Brian at Ironstone

    Brian at Ironstone New Pleskian

    15
    80%
    Joined:
    Jan 23, 2011
    Messages:
    5
    Likes Received:
    0
    SmartMail

    Hi AndorA,
    Thanks for the response. I have tried all those options, and every other option I could find searching the issue.

    I am running Plesk 10 and SmarterMail 7.4.
    I have double checked that the SmartMail server is stopped and disabled.
    I have tripple checked that Smarter Mail is running in a separate IIS App Pool with Identity NetworkService.
    The bindings in the SmarterMail site include my hostname and then the webmail address of each domains webmail URL.

    I am using port 9998, but I have tried port 25 to see if that helped. No luck.

    I have restarted my server...no luck.

    I have pulled my hair out...the only thing that did work.

    Cheers,
    Brian
     
  7. AndorA

    AndorA Basic Pleskian

    21
    57%
    Joined:
    Nov 30, 2009
    Messages:
    58
    Likes Received:
    0
    Oh don't pull your hair out now. It's just an e-mail program :)

    Just to be sure: if you say that SmarterMail runs properly as IIS program, does that mean that you can login through the web interface as admin?

    One more thing - SmarterMail runs with a default license of one domain or so. So if you did not add your own license number before connecting it to Plesk, it might cause all kinds of havoc as it tries to create more domains than it allows.

    If none of that works, and I were in your shoes, the thing I would try is run an older version of SmarterMail, e.g. the highest number that is officially supported as per the Plesk 10 release docs. I think that's 6.8 or so (last time I checked, but a new Plesk 10 update was released since). While 7.4 runs fine with me in Plesk 10, there might be other issues depending on your setup that won't exist with the latest Parallels-supported version.

    Good luck!
    Andor
     
  8. Brian at Ironstone

    Brian at Ironstone New Pleskian

    15
    80%
    Joined:
    Jan 23, 2011
    Messages:
    5
    Likes Received:
    0
    Yes I can login as admin through the web interface, or as any of the email accounts, on any of the domains that already existed.

    So I can use the admin account to set all the settings and to run the self diagnostics, all of which pass.

    I am running Pro, which has been activated, so I shouldn't be having any licensing issues.

    It's just that I can't get Plesk to correctly configure SmarterMail. Plesk sees SmarterMail and I can set as the default server along with the webmail client, it's just that it throughs the errors.

    I can't create any domains in Plesk because of a createDomain error when creating the email domain.

    I can manually create domains in SmarterMail with no problems.

    If I create the domain in SmarterMail and then try to create the domain in Plesk I get another error.

    So I'm guessing that Plesk can't call the SmarterMail API, possibly due to a permissions issue.

    SmarterMail is running in it's own App Pool with NetworkService as the Identify, which is the SmarterMail suggested setup, but perhapse that is not correct for Plesk.

    AndorA what is your Application Pool Identity, and what extra permissions did you set in the webmail site and for which users.? Did you set any other permissions?

    Thanks again for you time....still some hair left, but it's very short.
     
  9. AndorA

    AndorA Basic Pleskian

    21
    57%
    Joined:
    Nov 30, 2009
    Messages:
    58
    Likes Received:
    0
    Third response from the third airport on the third continent today :) Unfortunately on this airport Remote Desktop is blocked, so I cannot check my exact setup. But I'm pretty sure I used the recommended setup using a freshly created apppool named SmarterMail.

    Did you check this thing where you set the HTTP header response expiration on the App_Themes folder to 7 days? I remember I had some issues making SM itself work earlier because I didn't do that (why it would be important is still puzzling to me, but apparently it is). Also I'm on IIS7, other versions might react differently. Again, I would try to downgrade SmarterMail to see if that makes a difference.

    Good luck,
    Andor
     
  10. Brian at Ironstone

    Brian at Ironstone New Pleskian

    15
    80%
    Joined:
    Jan 23, 2011
    Messages:
    5
    Likes Received:
    0
    Hi AndorA,
    I didn't realise you were in transit. 3 replies from 3 continents shows commitment, or airport boredom. Thanks.
    I have made sure I set the HTTP_Header Response settings, so now I think I will have to downgrade. I have an open support ticket with SmarterMail, so I'm just getting their advise before I downgrade.

    Having said that I am feeling that if you got it to work then I should be able to as well, I just haven't found the right setting yet. I'll keep looking.

    Is anybody from Plesk able to help!
     
  11. AndorA

    AndorA Basic Pleskian

    21
    57%
    Joined:
    Nov 30, 2009
    Messages:
    58
    Likes Received:
    0
    The version I'm running is SM 7.4.3995. AppPool is indeed the SmarterMail pool as set up per instructions. Plesk version is 10.0.1.

    BTW, Plesk 10.1 will come out one of these days (if it's not already just released), you never know it might solve the problem.
     
  12. Brian at Ironstone

    Brian at Ironstone New Pleskian

    15
    80%
    Joined:
    Jan 23, 2011
    Messages:
    5
    Likes Received:
    0
    Resolved! The Smarter Mail Services had stopped running. So the website was running fine but the SmarterMail service was stopped. Why this happened I'm not sure.

    Administrator Tools -> Services Then scroll down to SmarterMail. There are two services listed are:
    SmarterMail Service
    SmarterMail Web Service

    Make sure these two services are started and set to automatic.

    I also noted that the MailEnable Services are all set to manual. I have asked SmarterMail to update their help so that these troubleshooting steps are listed.

    After this service was started then I could refresh the Server Components in Plesk, then go into the SmarterMail mail server, and just apply the login details and this time the details were accepted and the mail service was then configured.
     
  13. RichardMckenna

    RichardMckenna New Pleskian

    13
    60%
    Joined:
    Apr 22, 2011
    Messages:
    23
    Likes Received:
    0
    I have SmarterMail 8x and Plesk 10 installed on my server. I can only get it working with Plesk if I use SmarterMail with its own internal server. If I switch it to an IIS7 site Plesk just throws the Error: Some fields are empty or contain an improper value.

    Also I'm pretty sure the 2 services you refer to:

    SmarterMail Service
    SmarterMail Web Service

    The first one is the actual mail server, the second is the service for SmarterMail's internal web server. Which can be configured using the 'Configure SmaterMail Web Server' tool in the start menu.

    So I think your fix is effectively just to use SmarterMail's internal web server rather than set it up as an IIS7 site and link it that way.

    If anyone has any other thoughts on this I'd be interested to hear them.

    Richard
     
  14. Jon L

    Jon L Guest

    0
     
    Working fine for us with IIS, with the same versions. Where does Plesk show that error message?

    We did have one problem with setting the admin password for SM, some sort of conflict with Plesk thinking it was too or not enough complex. Think it was resolved by starting with the SM web server, setting the password to something very simple and then switching back.

    Can't remember for definite as we had SM do the install. Would be worth posting on their forums.
     
Loading...