1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ERROR: Can't execute gunzip

Discussion in 'Plesk for Linux - 8.x and Older' started by Voelcker, Mar 4, 2008.

  1. Voelcker

    Voelcker Guest

    0
     
    I was trying to update several packages using the plesk update from the Web Control Panel when I received the error about failed to update key. I found elsewhere on the web to run the autoinstaller from the command line instead as the problem is due to the plesk_updater package originally released with 8.3.0.

    When I run /usr/local/psa/admin/sbin/autoinstaller from the command line and accepting all the default options at the prompts the update fails with the following output:

    Retrieving information about the installed packages...
    Downloading the file PSA_8.3.0/dist-rpm-FedoraCore-6-i386/build-8.3.0-fc6-i386.hdr.gz: 24%..72%..100% done.
    Downloading the file PSA_8.3.0/update-rpm-FedoraCore-6-i386/update-8.3.0-fc6-i386.hdr.gz: 33%..66%..100% done.
    Downloading the file PSA_8.3.0/thirdparty-rpm-FedoraCore-6-i386/thirdparty-8.3.0-fc6-i386.hdr.gz: 100% done.
    ERROR: Can't execute gunzip

    I've uninstalled and reinstalled gzip (using yum) and the problem persists, when I run:

    # which gzip
    /bin/gzip
    # which gunzip
    /bin/gunzip

    So I know the executables are there, I've even tested them manually on the command line to make sure they are decompressing zipped files. It's as if the path to gunzip in autoinstaller is wrong (if that's even possible).

    Help!
     
  2. andres.moya

    andres.moya Guest

    0
     
    same problem.
     
  3. andres.moya

    andres.moya Guest

    0
     
    Use:
    vzctl exec 101 cat /proc/user_beancounters
    there change 101 on your plesk VEID. you will see one line like this:
    resource held maxheld barrier limit failcnt
    privvmpages 52978 73574 65536 69632 18
    look at 'failcnt' field to identify there you run out limits. should be more then 0.
    modify it with: vzctl set 101 --privvmpages 150000:200000 --save
    be happy.

    Most of young sysadmins have problem setting correct file permission, in our case we not used that we running resource limited systems. Making similar mistakes.
     
Loading...