1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Error Installing SiteBuilder (Again?)

Discussion in 'Legacy Sitebuilder Software' started by JohnDoel, Apr 3, 2005.

  1. JohnDoel

    JohnDoel Guest

    0
     
    When I try installing SiteBuilder using SSH, an error appear as below:
    error: Failed dependencies:
    php >= 4.3 is needed by Sitebuilder-1.1.1-rhel3.build050117.10
    php-mysql is needed by Sitebuilder-1.1.1-rhel3.build050117.10

    And then I checked my server system info, the results:
    =========================
    - Checking for PHP version:
    PHP version: 4.3.10
    Version ok
    PHP safe mode off

    - Checking for MySql version:
    MySQL version: 3.23.49
    Version ok

    - Checking for ImageMagick:
    ImageMagick not found in location. (Download CGI script to test ImageMagick without knowing path)

    - Checking for GD:
    GD Version: bundled (2.0.28 compatible)
    Version Ok

    PNG Support is enabled
    JPEG Support is enabled
    GIF Support is enabled
    WBMP Support is enabled
    Checking for GD 2.x:
    GD 2.x found

    - Trying to create image via GD 2.x:
    For atleast next 10 seconds, don't press anything, click retry when prompted to do so
    File creation was successful
    =================================
    Anyone how to fix them out?

    Thank you.
     
  2. rawkin

    rawkin Guest

    0
     
    > php >= 4.3 is needed by Sitebuilder-1.1.1-rhel3.build050117.10
    > php-mysql is needed by Sitebuilder-1.1.1-rhel3.build050117.10

    Check that you have the php-mysql package installed;
    # rpm -q php-mysql
    php-mysql-4.x.x-x.ent

    Once you have the php-mysql package installed, see if rpm is still showing php as a missing dependancy.

    If you're sure you definitely have both installed, you could try forcing the install anyway & seeing if it works;

    # rpm -ivh --nodeps SiteBuilder.xxx.rpm

    Pete
     
  3. JohnDoel

    JohnDoel Guest

    0
     
    You're right Pete, I can't found php-mysql package on my server. How do I Install them? My server currently running under RedHat Enterprise 3.
     
  4. rawkin

    rawkin Guest

    0
     
    If that machine is subscribed to RedHat Network, you can install php-mysql via up2date;

    # up2date php-mysql

    Otherwise you can install this package from your RHEL 3 CD's (disc 3);

    # rpm -ivh php-mysql.xxxx.rpm

    The RHN option is much better since it will ensure the php-mysql package is fully up to date.

    Pete
     
  5. JohnDoel

    JohnDoel Guest

    0
     
    php-mysql installation is done! but another error appears:
    -------------------------------------------------------
    error: cannot get exclusive lock on /var/lib/rpm/Packages
    error: cannot open Packages index using db3 - Operation not permitted (1)
    error: cannot open Packages database in /var/lib/rpm
    ---------------------------------------------------------------------
    Any Solutions?
     
  6. rawkin

    rawkin Guest

    0
     
    Are you installing the RPM as root? The error looks as though you're trying to install the RPM as a normal user.
     
Loading...