• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

ERROR: PleskMainDBException

M

MrApples

Guest
Apparently Plesk's database has been corrupted due to a bad-parsed my.cnf file during a reboot, at least 10 tables appear to have the 'Incorrect information' problem. I tried a variety of things in the SSH I found online to repair the MySQL, but unfortunately nothing has happened.

Service 'mysqld' is running

Code:
ERROR: PleskMainDBException
MySQL query failed: Incorrect information in file: './psa/misc.frm'

0: /usr/local/psa/admin/plib/common_func.php3:250
	db_query(string 'select param, val from misc')
1: /usr/local/psa/admin/plib/common_func.php3:562
	get_param(string 'mysql41_compatible')
2: /usr/local/psa/admin/plib/common_func.php3:459
	db_set_names()
3: /usr/local/psa/admin/plib/common_func.php3:438
	db_connect_real(string 'localhost', string 'admin', string '**********', string 'psa')
4: /usr/local/psa/admin/plib/common_func.php3:418
	db_connect()
5: /usr/local/psa/admin/auto_prepend/auth.php3:90

After restarting all services in the SSH...
Code:
ERROR 1033 (HY000) at line 1: Incorrect information in file: './psa/DomainServices.frm'
websrvmng: DB error (mysql41 compatible query) 1033: Incorrect information in file: './psa/misc.frm'
websrvmng: DB error (mysql41 compatible query) 1033: Incorrect information in file: './psa/misc.frm'
websrvmng: Unable to connect to the mysql database
websrvmng: Unable to connect to the mysql database
ERROR 1033 (HY000) at line 1: Incorrect information in file: './psa/sessions.frm'
Starting Plesk...                                                    done
ERROR 1033 (HY000) at line 1: Incorrect information in file: './psa/misc.frm'

If anyone could offer some assistance on this that would be great. Apache is still running, but the cP and MySQL are dead.
 
Back
Top