1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Error suspending domains during backup

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by KamilR, Nov 17, 2011.

  1. KamilR

    KamilR Basic Pleskian

    22
     
    Joined:
    Jun 24, 2009
    Messages:
    67
    Likes Received:
    0
    After upgrading to 10.4.4, every backup task gives error: "Turn off domain failed: Bad session type." for every domain.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
  3. KamilR

    KamilR Basic Pleskian

    22
     
    Joined:
    Jun 24, 2009
    Messages:
    67
    Likes Received:
    0
    PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE

    10.4.4, Debian 6 x64

    PROBLEM DESCRIPTION AND STEPS TO REPRODUCE

    Turn on scheduled backups and check "Suspend domains until backup task is completed". Backup will be completed but with a list of "Turn off domain failed: Bad session type." errors for every domain.

    ACTUAL RESULT

    Backup created, but with errors.

    EXPECTED RESULT

    Backup created without any errors.

    ANY ADDITIONAL INFORMATION

    Backup log:

    <?xml version="1.0" encoding="UTF-8"?>
    <execution-result status="error" log-location="/opt/psa/PMM/sessions/2011-11-17-040308.499/migration.result">
    <object name="XXX" type="client">
    <object name="XXX" type="domain">
    <message id="3cc43647-26b8-4385-8983-f7a79c4805d9" severity="warning" code="SuspendFailed">
    <description>The domain 'XXX' was not suspended during backup!</description>
    </message>
    <message id="7157e35e-0991-48b3-887b-5ef0fd3284e5" severity="error" code="UtilityError">
    <description>Cannot suspend domain 'XXX' (ErrorCode: 1, STDOUT:Turn off domain failed: Bad session type.
    ) [Error:]. This is not fatal error!</description>
    </message>
    </object>
    </object>

    ... for every domain
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Thank you for report. I have forwarded it to developers. I will keep this thread updated with results of investigation.
     
  5. KamilR

    KamilR Basic Pleskian

    22
     
    Joined:
    Jun 24, 2009
    Messages:
    67
    Likes Received:
    0
    More info: after each (failed) backup task, certain subdomains have DNS disabled.
     
  6. Igor Z.

    Igor Z. Guest

    0
     
    I've tried to reproduce the issue - is not reproducing here. Could you please provide me with the following information:
    1. Does simple (non-scheduled) backup work?
    2. Was it upgrade? If yes - from which Plesk version you have upgraded?
     
  7. KamilR

    KamilR Basic Pleskian

    22
     
    Joined:
    Jun 24, 2009
    Messages:
    67
    Likes Received:
    0
    I can confirm the error in non-scheduled backups. I also confirm disabled DNS service for random domains after the backup (tooltip in DNS control panel says the domain has been disabled).
    I have upgraded the panel from 10.3.1

    Without 'disable domains' everything is ok.
     
  8. KamilR

    KamilR Basic Pleskian

    22
     
    Joined:
    Jun 24, 2009
    Messages:
    67
    Likes Received:
    0
    Just found another symptom - random domain aliases remain disabled.
     
  9. KamilR

    KamilR Basic Pleskian

    22
     
    Joined:
    Jun 24, 2009
    Messages:
    67
    Likes Received:
    0
    The same problem exists with clean installation of the latest verion and migrating data from 10.4.4 #7.
     
  10. idys

    idys Guest

    0
     
    Hi,

    I confirm, since upgrade to 10.4.4, I have same problem when backuping, all my subdomains are suspended !?

    Please find enclosed last log file (renamed to be enclosed).

    Thx by advance for any clue to correct this problem !

    Rgds,
     

    Attached Files:

    Last edited by a moderator: Jan 2, 2012
  11. idys

    idys Guest

    0
     
  12. UweP

    UweP Regular Pleskian

    26
     
    Joined:
    Sep 23, 2010
    Messages:
    252
    Likes Received:
    0
  13. Ole SverreH

    Ole SverreH Guest

    0
     
    Same problem

    Hello.

    I have the same problem after upgrading from 10.3 to 10.4.
    My server does automatic backups every night, and i have turned on the option for suspending domains while backup.
    After this is done, some domain aliases wont be activated again after the backup is done.

    I retrieve this status report:

    <?xml version="1.0" encoding="UTF-8"?>
    <execution-result status="error" log-location="/opt/psa/PMM/sessions/2012-01-11-032501.595/migration.result">
    <object name="knut.mork" type="client">
    <object name="ontimebemanning.no" type="domain">
    <message id="f62b1a73-164e-416a-8fd8-fa01d756cd9f" severity="warning" code="SuspendFailed">
    <description>The domain 'ontimebemanning.no' was not suspended during backup!</description>
    </message>
    <message id="d32479a8-75d6-46ee-8835-2b67f5108d50" severity="error" code="UtilityError">
    <description>Cannot suspend domain 'ontimebemanning.no' (ErrorCode: 1, STDOUT:Turn off domain failed: Bad session type.
    ) [Error:]. This is not fatal error!</description>
    </message>
    </object>
    </object>
    <object name="simen.navarsete" type="client">
    <object name="volvoklubbentrondelag.no" type="domain">
    <message id="3965f3b5-457c-4877-807d-e22a13701d76" severity="warning" code="SuspendFailed">
    <description>The domain 'volvoklubbentrondelag.no' was not suspended during backup!</description>
    </message>
    <message id="f19ab61c-fc92-4700-8c47-d544d43e6e6b" severity="error" code="UtilityError">
    <description>Cannot suspend domain 'volvoklubbentrondelag.no' (ErrorCode: 1, STDOUT:Turn off domain failed: Bad session type.
    ) [Error:]. This is not fatal error!</description>
    </message>
    </object>
    </object>
    <object name="vegar.granheim" type="client">
    <object name="viersterk.no" type="domain">
    <message id="f96e26a3-6213-42de-8567-f12596d1262e" severity="warning" code="SuspendFailed">
    <description>The domain 'viersterk.no' was not suspended during backup!</description>
    </message>
    <message id="b1cee2c4-9aea-49c0-89e9-d2e0ddc1b2d2" severity="error" code="UtilityError">
    <description>Cannot suspend domain 'viersterk.no' (ErrorCode: 1, STDOUT:Turn off domain failed: Bad session type.
    ) [Error:]. This is not fatal error!</description>
    </message>
    </object>
    </object>
    <object name="itvault.no" type="domain">
    <message id="56287856-3226-4c97-8b25-d7656375fe46" severity="warning" code="SuspendFailed">
    <description>The domain 'itvault.no' was not suspended during backup!</description>
    </message>
    <message id="b874ec37-382b-4d56-8103-b4fb8dea05ef" severity="error" code="UtilityError">
    <description>Cannot suspend domain 'itvault.no' (ErrorCode: 1, STDOUT:Turn off domain failed: Bad session type.
    ) [Error:]. This is not fatal error!</description>
    </message>
    <object name="itvault.no" type="hosting">
    <object name="dev.itvault.no" type="domain">
    <message id="acfcd3e4-ec46-40d5-829c-aeb4a72aef0c" severity="warning" code="SuspendFailed">
    <description>The domain 'dev.itvault.no' was not suspended during backup!</description>
    </message>
    <message id="71928835-2f7c-4fff-8b63-0a55efdd04fb" severity="error" code="UtilityError">
    <description>Cannot suspend domain 'dev.itvault.no' (ErrorCode: 1, STDOUT:Turn off domain failed: Bad session type.
    ) [Error:]. This is not fatal error!</description>
    </message>
    </object>
    <object name="cayenne.itvault.no" type="domain">
    <message id="ce6c0339-2467-46d3-885c-2d08847be483" severity="warning" code="SuspendFailed">
    <description>The domain 'cayenne.itvault.no' was not suspended during backup!</description>
    </message>
    <message id="9ef22285-f9ec-4d96-8bef-3f25872ae856" severity="error" code="UtilityError">
    <description>Cannot suspend domain 'cayenne.itvault.no' (ErrorCode: 1, STDOUT:Turn off domain failed: Bad session type.
    ) [Error:]. This is not fatal error!</description>
    </message>
    </object>
    </object>
    </object>
    <object name="hawebdesign.no" type="domain">
    <message id="540d9be8-01cc-4820-8fc4-026872705e77" severity="warning" code="SuspendFailed">
    <description>The domain 'hawebdesign.no' was not suspended during backup!</description>
    </message>
    <message id="b46d4f67-22fb-4062-83cb-7ddebdb87c29" severity="error" code="UtilityError">
    <description>Cannot suspend domain 'hawebdesign.no' (ErrorCode: 1, STDOUT:WebServerManager::reconfVhost() failed: Unable to load object of type PhDomain with id=25: Turn off domain failed: Bad session type.
    ) [Error:]. This is not fatal error!</description>
    </message>
    <object name="hawebdesign.no" type="hosting">
    <object name="admin.hawebdesign.no" type="domain">
    <message id="41c32119-b112-4ce6-8e70-aeea44cbe9d5" severity="warning" code="SuspendFailed">
    <description>The domain 'admin.hawebdesign.no' was not suspended during backup!</description>
    </message>
    <message id="5a4ba2ba-6c04-4882-8bf6-a9a27d50974b" severity="error" code="UtilityError">
    <description>Cannot suspend domain 'admin.hawebdesign.no' (ErrorCode: 1, STDOUT:Turn off domain failed: Bad session type.
    ) [Error:]. This is not fatal error!</description>
    </message>
    </object>
    <object name="v1.hawebdesign.no" type="domain">
    <message id="6580ab55-960c-47f1-89d3-6578acfdc516" severity="warning" code="SuspendFailed">
    <description>The domain 'v1.hawebdesign.no' was not suspended during backup!</description>
    </message>
    <message id="55f46621-d5d3-45cb-86a6-4db8c4b1135f" severity="error" code="UtilityError">
    <description>Cannot suspend domain 'v1.hawebdesign.no' (ErrorCode: 1, STDOUT:Turn off domain failed: Bad session type.
    ) [Error:]. This is not fatal error!</description>
    </message>
    </object>
    <object name="dev.hawebdesign.no" type="domain">
    <message id="4e76f85c-a325-46b6-8526-78fc4ca19c16" severity="warning" code="SuspendFailed">
    <description>The domain 'dev.hawebdesign.no' was not suspended during backup!</description>
    </message>
    <message id="9a7994f8-c1e6-4e77-8048-673aa9099494" severity="error" code="UtilityError">
    <description>Cannot suspend domain 'dev.hawebdesign.no' (ErrorCode: 1, STDOUT:Turn off domain failed: Bad session type.
    ) [Error:]. This is not fatal error!</description>
    </message>
    </object>
    <object name="dev2.hawebdesign.no" type="domain">
    <message id="4e442831-9f2c-4e40-84b2-875f362d2303" severity="warning" code="SuspendFailed">
    <description>The domain 'dev2.hawebdesign.no' was not suspended during backup!</description>
    </message>
    <message id="8847ae1e-66a7-44ca-890d-a14c81152f56" severity="error" code="UtilityError">
    <description>Cannot suspend domain 'dev2.hawebdesign.no' (ErrorCode: 1, STDOUT:Turn off domain failed: Bad session type.
    ) [Error:]. This is not fatal error!</description>
    </message>
    </object>
    </object>
    </object>
    <object name="steelz.no" type="domain">
    <message id="fdaf4701-0e71-403a-8e03-df46a2ee77b1" severity="warning" code="SuspendFailed">
    <description>The domain 'steelz.no' was not suspended during backup!</description>
    </message>
    <message id="e7253044-4207-46ea-81b2-cffac369aa7e" severity="error" code="UtilityError">
    <description>Cannot suspend domain 'steelz.no' (ErrorCode: 1, STDOUT:Turn off domain failed: Bad session type.
    ) [Error:]. This is not fatal error!</description>
    </message>
    </object>
    </execution-result>
     
  14. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Try to use attached custom fix. File /opt/psa/admin/plib/class.Session.php should be replaced. Do not forget to backup original file just in case.
     

    Attached Files:

  15. ChrisE@

    ChrisE@ Guest

    0
     
    Manuell backup worked for me with this fix without errors. thanks a lot.
     
  16. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Only manual? What about scheduled backup?
     
Loading...