1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

even bigger problems - urgent!

Discussion in 'Plesk for Linux - 8.x and Older' started by manarak, Oct 25, 2005.

  1. manarak

    manarak Guest

    0
     
    even bigger MAIL problems

    After upgrading to 7.5.4 I had the problem that mail was not working at all.
    I uninstalled, reinstalled qmail, scanner, clamav, etc.
    The smtp_psa files are OK too.
    There's no watchdog, no drweb.

    I rebooted the server.

    Now, not only the mail doesn't work, but the Plesk control panel login has disappeared too! (yes, the one with https: and 8443)
    => page/server not found!

    I tried restarting psa.
    It tells PSA is down, performing full start.
    I get an OK.

    I retry to start psa, and it tells me PSA is down, full start again.

    It seems I can never get it to run.

    Can someone help me fix these 2 problems?
     
  2. manarak

    manarak Guest

    0
     
    ok, a reboot solved the plesk panel problem.

    now, I still have the problem that no mail, incoming and outbound is working.
     
  3. manarak

    manarak Guest

    0
     
    hmmmmmm...

    in /usr/local/psa/var/log/maillog

    I see "deferral - sorry, message has wrong owner"

    how to fix this?
     
  4. manarak

    manarak Guest

    0
     
    found this in a mailinglist archive:

    does someone understand what this is about and how I can fix the mail?
     
  5. CoKo

    CoKo Guest

    0
     
    please tell me the output of

    ls -al /var/qmail/bin
     
  6. manarak

    manarak Guest

    0
     
    here it is:

     
  7. CoKo

    CoKo Guest

    0
     
    Please try the following:

    chown qmailq /var/qmail/bin/qmail-queue.orig
     
  8. manarak

    manarak Guest

    0
     
    ok, did that.

    restarted qmail

    It seems I can now receive and send mails.
    Thank you!

    Any idea how to get the message queue delivered?
     
  9. CoKo

    CoKo Guest

    0
     
    with

    killall -ALRM qmail-send

    you can force qmail to process the queue
     
  10. manarak

    manarak Guest

    0
     
    thank you, you are a lifesaver!
     
  11. CoKo

    CoKo Guest

    0
     
    You're welcome.

    I've had the same problems when starting to work with qmail 12 month ago....
     
  12. manarak

    manarak Guest

    0
     
    I wonder if the queue is being delivered.
    I receive no mails.
     
  13. manarak

    manarak Guest

    0
     
    yep - the messages are still there, not delivered.
     
  14. CoKo

    CoKo Guest

    0
     
    Mind to give the the result of a

    ps -ef | grep qmail

    ?
     
  15. manarak

    manarak Guest

    0
     
    qmailq owns clamd
    qmails owns qmail-send
    qmaill owns splogger qmail
    root owns qmail-lspawn ./Maildir/
    qmailr owns qmail-rspawn
    qmailq owns qmail-clean
    root owns grep qmail
     
  16. CoKo

    CoKo Guest

    0
     
    Uhmmm - Interesting output. That's of no help. you can neither see how many of the processes are running nore since when.

    However, the following should start queue processing immediately:

    service qmail stop
    killall -9 qmail-rspawn
    killall -9 qmail-lspawn
    killall -9 qmail-send
    killall -9 qmail-clean
    service qmail start

    Please be aware that the standard settings for qmail only allow parallel processing of 10 incoming and 20 outgoing mails. So if your queue is really full and there are some lame servers you need to send to, it will take time...
     
  17. manarak

    manarak Guest

    0
     
    sorry. here it is

    qmailq 1722 1 0 20:33 ? 00:00:00 clamd
    qmails 3953 1 0 22:20 pts/0 00:00:00 qmail-send
    qmaill 3955 3953 0 22:20 pts/0 00:00:00 splogger qmail
    root 3956 3953 0 22:20 pts/0 00:00:00 qmail-lspawn ./Maildir/
    qmailr 3957 3953 0 22:20 pts/0 00:00:00 qmail-rspawn
    qmailq 3958 3953 0 22:20 pts/0 00:00:00 qmail-clean
    root 3998 2296 0 22:21 pts/0 00:00:00 grep qmail -



    the killall -9 commands all resulted in "no process killed".
    queue still there.
     
  18. CoKo

    CoKo Guest

    0
     
    I guess "queue still there" means the output of /var/qmail/bin/qmail-qstat right?

    I fear you've got now broken mails in the queue. There IS a way to rebuild the queue completely - but this means a total loss of all mails in the queue.

    Please check with /var/qmail/bin/qmail-qread if the mails are qorth to be kept - otherwise I will tell you how to rebuild your queue
     
  19. manarak

    manarak Guest

    0
     
    messages in queue: 239
    not preprocessed: 0

    there are messages from customers there!
    you mean qmail cannot process them anymore?
     
  20. CoKo

    CoKo Guest

    0
     
    ps ax | grep qmail-send
    kill -ALRM <pid_number>

    You may need to run /var/qmail/bin/qmail-tcpok before sending the ALRM signal to clear the qmail tcp timeout table, or qmail will wait till retry times are reached before it again attempts to send messages.

    It's the only way I know to force qmail to process the queue immediately. If this doesn't work....

    BTW: Did you remove the virusscanner from all .qmail files?
     
Loading...