• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

fail2ban fails to enable new jails

H9k

Regular Pleskian
Running Debian 7.9 and Plesk 12.5 update 1.
I want to enable plesk-wordpress and plesk-modsecurity, but it fails:

Code:
Unable to switch on the selected jails: f2bmng failed: ERROR NOK: ('Invalid command (no set action or not yet implemented)',)
ERROR NOK: ("invalid literal for int() with base 10: 'INFO'",)
ERROR NOK: ('Invalid command (no set action or not yet implemented)',)
ERROR NOK: ('Invalid command (no set action or not yet implemented)',)
ERROR NOK: (2, 'No such file or directory')
ERROR NOK: ('Invalid command (no set action or not yet implemented)',)
...
ERROR NOK: ('Invalid command (no set action or not yet implemented)',)
ERROR:f2bmng:Command '['/usr/bin/fail2ban-client', 'reload', 'plesk-modsecurity']' returned non-zero exit status 255
ERROR NOK: ('Invalid command (no set action or not yet implemented)',)
ERROR NOK: ("invalid literal for int() with base 10: 'INFO'",)
ERROR NOK: ('Invalid command (no set action or not yet implemented)',)
ERROR NOK: ('Invalid command (no set action or not yet implemented)',)
ERROR NOK: (2, 'No such file or directory')
...
ERROR NOK: (2, 'No such file or directory')
ERROR NOK: ('Invalid command (no set action or not yet implemented)',)
...
ERROR NOK: ('Invalid command (no set action or not yet implemented)',)
ERROR:f2bmng:Command '['/usr/bin/fail2ban-client', 'reload', 'plesk-wordpress']' returned non-zero exit status 255
ERROR:f2bmng:Failed to reload following jails due to errors in configuration: plesk-modsecurity, plesk-wordpress
 
Hmmm maybe the reason was I already had my own jail named "wordpress".
I removed it, and now I was able to enable the jails properly.
 
Back
Top