1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

"Failed to upload the migration agent"

Discussion in 'Plesk for Linux - 8.x and Older' started by tempest, May 18, 2005.

  1. tempest

    tempest Guest

    0
     
    Can anyone please help, this is very urgent. :(

    I am trying to move several domains/sites from my client's old server to a new one. Both have Plesk Reloaded (7.5 i think, but not sure how to check). Anyway, I am trying to follow the documentation and trying to use Migration Manager to move the domains over.

    However, when I try to upload the migration agent from the new server to the old one, using root as the account, it says:

    It's giving me absolutely no more clues as to why this is happening. I don't even know how the migration manager is attempting to connect to the old server - is it via ftp or ssh or other? Perhaps it's something to do with ssh access or something?

    Looking forward to some help. :/
    Thanks in advance,
    tempest.
     
  2. tempest

    tempest Guest

    0
     
    well.. i have managed to temporarily allow ssh access on the old host, and now the Migration Manager on the new host seems to be connecting, but is forever refreshing the "Uploading Migration Agent" page..... not sure how long its supposed to take, but ive been here 20 minutes now... :(

    i really hope i can get this to work...
     
  3. dm__@

    dm__@ Guest

    0
     
    AFAIR, it was a very short operation to upload the agent. Does the PleskX.pl exist in /root/migration/<some-number-here> or /migration/<some-number-here> directory on the old host? Try to start it with ./PleskX -s.

    BTW, there is log of migration in /usr/local/psa/PMM/var/migration.log on the new host, it contains detailed information about the process. Unfortunately, log file looks really 'debuggish'.
     
  4. tempest

    tempest Guest

    0
     
    I have looked in /root/ and there is no sign of any migration dir. :(

    This is my migration.log, but as you said, its very "debuggish"... The only line I can see which might be a clue is where it says 'data[No suitable authentication method found'. What could this mean? I have temporarily enabled ssh for root, and can login using putty, so that can't be it can it? Or is it that both servers have to have ssh enabled?

    I really need help. :(

    The last few lines are repeated over and over with different pids, presumable in conjuction with the page refreshes on Plesk.

    Can anyone see the problem?? :(
     
  5. dm__@

    dm__@ Guest

    0
     
    I've seen the 'No suitable ...' message in logs only when I passed the wrong password, so it seems really to be an authentication problem. May be Migration Manager and remote ssh are trying to use different authentication methods (keyboard-interactive, and password, and whatever else SSH protocol allows)? BTW, I've found that /usr/local/psa/admin/sbin/ssh-lite (mentioned in the log above) is like regular 'ssh' (I don't know why does this exist, may be some patches they wanted or just compatibility issues), so you can try to play with this utility to see can it connect to the your old server, and if it can't you may try to contact support team - may be it's a bug in Migration Manager, not the unusual ssh daemon settings.

    And, yes, I migrated _to_ the server with carefully firewalled ssh. Everything went fine.
     
  6. Chris

    Chris Guest

    0
     
    Try SSH-ing as root from one server to the other to verify you can log in. Also make sure wget is enabled on the server that migration manager is trying to log in to.
     
  7. dm__@

    dm__@ Guest

    0
     
    Nope, wget is not needed.
     
  8. rank1st

    rank1st Guest

    0
     
    Just a short note that I thought I would add after scratching my head for an hour:

    Check the "Other" radio button and put in the username root. It worked for me.
     
Loading...