• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Failed with message: Empty error message from utility.

AlexanderPolizu

New Pleskian
Hi Guys,

I had a system crush and after server reboot many *httpd.include files are missing so I can't restart apache

[root@vps01 ~]# service httpd restart
Stopping httpd: [FAILED]
Starting httpd: [Thu Aug 23 09:41:18 2012] [warn] module ssl_module is already loaded, skipping
httpd: Syntax error on line 212 of /etc/httpd/conf/httpd.conf: Syntax error on line 8 of /etc/httpd/conf.d/zz010_psa_httpd.conf: Syntax error on line 536 of /usr/local/psa/admin/conf/vhosts_bootstrap.conf: Could not open configuration file /var/www/vhosts/xxx.com/conf/13456683200.14443500_httpd.include: No such file or directory

I have tried to recreate the include files with

/usr/local/psa/admin/sbin/httpdmng --reconfigure-all

but it fails with the following error

# /usr/local/psa/admin/sbin/httpdmng --reconfigure-all
PleskUtilException: '/usr/local/psa/admin/bin/apache-config' '-t' failed with code .

stdout:


stderr:
[Thu Aug 23 09:39:47 2012] [warn] module ssl_module is already loaded, skipping
httpd: Syntax error on line 212 of /etc/httpd/conf/httpd.conf: Syntax error on line 8 of /etc/httpd/conf.d/zz010_psa_httpd.conf: Syntax error on line 536 of /usr/local/psa/admin/conf/vhosts_bootstrap.conf: Could not open configuration file /var/www/vhosts/xxx.com/conf/13456683200.14443500_httpd.include: No such file or directory

file: /usr/local/psa/admin/plib/Service/Agent/Transport/Local/Exec.php
line: 71
code: 0
trace: #0 /usr/local/psa/admin/plib/Service/Agent/Transport/Local.php(58): Service_Agent_Transport_Local_Exec->process(5, Object(Service_Agent_Command_Exec), Object(Service_Agent_Log), Object(Service_Agent_Transport_LocalTransaction))
#1 /usr/local/psa/admin/plib/Service/Agent/Transport/Local.php(24): Service_Agent_Transport_Local->_command(5, Object(Service_Agent_Command_Exec), Object(Service_Agent_Transport_LocalTransaction), Object(Service_Agent_Log))
#2 /usr/local/psa/admin/plib/Service/Agent.php(133): Service_Agent_Transport_Local->process('435a3d643c262eb...', Array, Object(Service_Agent_Log))
#3 /usr/local/psa/admin/plib/Template/Writer/Apache.php(58): Service_Agent->commit()
#4 /usr/local/psa/admin/plib/Template/Configuration/Applier.php(196): Template_Writer_Apache->test()
#5 /usr/local/psa/admin/plib/Template/Configuration/Applier.php(117): Template_Configuration_Applier->_applyConfigurationsToServiceNode(1, Array)
#6 /usr/local/psa/admin/plib/WebServerManager/Adapter/Apache.php(125): Template_Configuration_Applier->applyConfiguration(true)
#7 /usr/local/psa/admin/plib/WebServerManager/Adapter/Apache.php(313): WebServerManager_Adapter_Apache->sync()
#8 /usr/local/psa/admin/plib/WebServerManager.php(199): WebServerManager_Adapter_Apache->reconfigureServer(Object(Db_Table_Row_ServiceNode))
#9 /usr/local/psa/admin/plib/api-common/Httpdmng.php(123): WebServerManager->reconfServer()
#10 /usr/local/psa/admin/sbin/httpdmng(13): Httpdmng->__construct()
#11 {main}

2012-08-23T09:39:48-04:00 ERR (3): Apache config (13457291870.05389000) generation failed: [Thu Aug 23 09:39:47 2012] [warn] module ssl_module is already loaded, skipping
httpd: Syntax error on line 212 of /etc/httpd/conf/httpd.conf: Syntax error on line 8 of /etc/httpd/conf.d/zz010_psa_httpd.conf: Syntax error on line 536 of /usr/local/psa/admin/conf/vhosts_bootstrap.conf: Could not open configuration file /var/www/vhosts/xxx.com/conf/13456683200.14443500_httpd.include: No such file or directory

[Thu Aug 23 09:39:47 2012] [warn] module ssl_module is already loaded, skipping
httpd: Syntax error on line 212 of /etc/httpd/conf/httpd.conf: Syntax error on line 8 of /etc/httpd/conf.d/zz010_psa_httpd.conf: Syntax error on line 536 of /usr/local/psa/admin/conf/vhosts_bootstrap.conf: Could not open configuration file /var/www/vhosts/xxx.com/conf/13456683200.14443500_httpd.include: No such file or directory

PleskUtilException: /usr/local/psa/admin/bin/httpdmng '--reconfigure-server' '-no-restart' failed with message: Empty error message from utility.
file: /usr/local/psa/admin/plib/common_func.php3
line: 1065
code: 0
trace: #0 /usr/local/psa/admin/plib/common_func.php3(983): util_exec('httpdmng', Array, Array, 'msg', NULL)
#1 /usr/local/psa/admin/plib/Os.php(17): smart_exec('httpdmng', Array, Array, 'msg')
#2 /usr/local/psa/admin/plib/Os.php(28): Os::exec('httpdmng', Array, 'msg')
#3 /usr/local/psa/admin/plib/api-common/Httpdmng.php(89): Os::execEx('httpdmng', Array)
#4 /usr/local/psa/admin/sbin/httpdmng(13): Httpdmng->__construct()
#5 {main}

Execution failed.
Command: httpdmng
Arguments: Array
(
[0] => --reconfigure-server
[1] => -no-restart
)

Details: Empty error message from utility.

Can someone help to fix this? Thank you.
 
Back
Top