1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

"failure notice" email to root@hostname.hostname

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by schlingel, Nov 15, 2009.

  1. schlingel

    schlingel Guest

    I just upgraded from 8.6 to 9.2.3 and everything went smooth (luckily) but now I keep getting email bounces. The weird thing, those Mails are supposed to go to root (cron results and such).

    Assume my Hostname is X1234, the emails can't be delivered, as they can be deliverd to root@X1234.X1234 as the Host X1234.X1234 can't be found. Of course it can't, it doesn't exist, it should be X1234

    I checked the hostname settings in Plesk, checked hostname on the shell and checked YAST too, there is the correct hostname everywhere. So does anyone have an idea where this might come from?

    Here is one of the emails:
  2. IgorG

    IgorG Forums Analyst Staff Member

    Oct 27, 2009
    Likes Received:
    Novosibirsk, Russia
    Try to check content of /var/qmail/control/locals file.
    Try to rebuild mail configuration with

    /usr/local/psa/admin/sbin/mchk --with-spam

    I hope it will help.
  3. schlingel

    schlingel Guest

    Thanks a lot.
    After the update, the hostname was incorrect but displayed correctly in the Plesk Interface. So I reset it. run mchk, and restarted Qmail. That solved the problem.

    Thanks again for pointing me in the right direction.
  4. PTS

    PTS New Pleskian

    Nov 20, 2009
    Likes Received:
    How to you check the hostname via CLI? I'm having the same issue you had and nothing I've done has been able to resolve the issue.

    I'm also getting a few other cron error emails each night which might be caused if the hostname is incorrect.
  5. schlingel

    schlingel Guest

    Simply with the command:
    In essence, Changing your Hostname in the Plesk admin interface so something completely different and then back to the real hostname should do the trick.
    Dont forget to run mchk, and restart Qmail afterwards